Unable to download/upload documents using SharePoint via browsers after installaing Protection for SharePoint servers
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Unable to download/upload documents using SharePoint via browsers after installaing Protection for SharePoint servers

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Article ID: 156345

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Updated On:

Products

Scan Engine Protection for SharePoint Servers

Issue/Introduction

You have installed Protection for SharePoint Servers in your environment and are no longer able to download documents via browser links from your database.

<nativehr>0x80041054</nativehr><nativestack>stswel.dll: (unresolved symbol, module offset=0000000000168ff4) at 0x000007fef29e8ff4

Exception from HRESULT: 0x80041054

 

 

Cause

When files are accessed in this way it is likely transfering over port 443. This will cause both Scan Engine and SharePoint to see this as an Encrypted Container.

Resolution

Allow encrypted containers in both the Scan Engine settings and the SharePoint console.

In Scan Engine:

  • Log into the console (https://<server IP address>:8004).
  • On the left hand side click on Policies.
  • Expand the center column and click on Filtering.
  • Click on the Container Handling tab at the top.
  • Uncheck the box next to "Delete encrypted containers".
  • Click on Apply and Save in the upper left hand corner.

Applies To

Protection for SharePoint Servers running in a Farm Environment.
Browsers are utilized to access files via HTML sites in an intra/extra net via HTTPS.
Potentially using 3rd party database software such as StoragePoint that is accessed via SQL.