Symantec Protection Engine service won't start and URL definitions do not get updated on servers running on Windows platforms.
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Symantec Protection Engine service won't start and URL definitions do not get updated on servers running on Windows platforms.

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Article ID: 157134

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

 

The Symantec Protection Engine service doesn't start and the URL definitions do not get updated on the server running on Windows platforms. In some cases, the Symantec Protection Engine service crashes while updating the definitions, while in other cases, the LiveUpdate page shows the URL definition status as “Rolled Back”.

You might see following if Symantec Protection Engine doesn't start:

1. SymantecProtectionEngineAbortLog.txt in "Scan Engine" directory might contain similar entries:

012/12/19-13:42:45 400 CSAPI failed to initialize.
2012/12/19-13:42:45 0 Symantec Protection Engine is shutting down; logs may contain more information.
 

2. Symantec Protection Engine logs might contain similar entries:

"URL scanner initialization failed"

Cause

Corrupt URL Definitions

Resolution

Solution #1: SPE can be reinstalled without activating URL definitions during installation phase resulting in removing the corrupt definitions. If you have configured your ICAP connector to use the URL features, they may be enabled after installation to restore these definitions.

 

Solution #2: Disable the URL features thereby preventing the use of the corrupted definitions. 

 

See the instructions for Disabling/Enabling URL filtering for the above solutions.