Blank page or Server error when opening Manage Tab in console
search cancel

Blank page or Server error when opening Manage Tab in console

book

Article ID: 158703

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

After upgrading the Enhanced Console Views using the Symantec Installation Manager some pages will not load and show a server error in '/Altiris/ActivityCenter' Application. Some of these pages include 

Manage > computers

Manage > policies

Manage > Jobs and Tasks

 

 

 

Error found in the NS logs when loading the page that fails:

[1] 11/20/2013 1:45:17 PM (w3wp) Altiris.NS.UI.AltirisWebApplication.Application_Error

Unhandled exception.

 System.IO.FileNotFoundException (Altiris.NS.Silverlight.ActivityCenter.Web): Could not load file or assembly 'Altiris.ActivityCenter, Version=7.5.1597.0, Culture=neutral, PublicKeyToken=6914135350bc86b7' or one of its dependencies. The system cannot find the file specified.

at Altiris.NS.Silverlight.ActivityCenter.Web.Default.Page_Load(Object sender, EventArgs e)

at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)

at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)

at System.Web.UI.Control.OnLoad(EventArgs e)

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

 

Cause

This seems to be caused by a corruption during the upgrade process.

 

Resolution

1. Navigate to 'Program Files\Altiris\Symantec Installation Manager\Installs\Altiris'

2. Right-click on the msi package for the altiris activity center hotifx and choose 'Uninstall'

3. Next right-click on the msi package for the altiris activity center (pre hotfix) and choose 'Uninstall'

4. Now open up an administrative command prompt and install the original activity center msi package (pre hotfix) by running the following command:  'msiexec /i <path-to-msi-file> skipaim=1'

5. Next open up an administrative command prompt and install the activity center hotfix msi package by running the following command:  'msiexec /i <path-to-msi-file> skipaim=1'

If after following these steps the console does not load any submenu within the Manage tab:

1. Clear browser cache

2. Clear the silverlight web pages under application storage within silverlight itself.

3. Reload the console.

 

 

 

Applies To

 

SMP 7.X

SMP 8.X