Unable to edit the Cloud-enabled Management agent IIS web site settings in the console
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Unable to edit the Cloud-enabled Management agent IIS web site settings in the console

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Article ID: 159028

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Updated On:

Products

IT Management Suite

Issue/Introduction

The current implementation of the console does not allow you to change these settings after it has been set up.   Even if you delete the site from IIS you will still not be able to edit them.

There is no an error.  You only have the option of changing the port that the CEM agents are using.

Environment

ITMS 8.x

Cause

Changing this information could cause you to have issues with the certificates that are being used.

Resolution

If you need to change these settings, you can do the following:

Note: it is a best practice to make a backup of any registry that is been edited/changed/deleted

  1. Stop Altiris Support Service, Altiris Service and the World Wide Web Publishing Service
  2. Remove the "Symantec Agent" website from IIS
  3. Delete the "HKLM\Software\Altiris\NS Agent Site" key
  4. Delete from "HKLM\software\Altiris" the "TsSecondaryWebSite" value.
  5. Delete from "HKLM\software\Altiris" the "AgentWebSite" value.  Make sure you only delete the one value.
  6. Restart the services stopped in step 1
  7. Open the console and you should be able to recreate the setting in the Cloud-enabled Management Agent IIS Website Settings.