Cannot access SharePoint pages while Symantec Protection Engine server is shown offline on Symantec Protection for SharePoint console.
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Cannot access SharePoint pages while Symantec Protection Engine server is shown offline on Symantec Protection for SharePoint console.

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Article ID: 159156

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Updated On:

Products

Protection for SharePoint Servers

Issue/Introduction

Symantec Protection Engine (SPE) server status is displayed as offline under "List and Edit all registered Symantec Protection Engines" on Symantec Protection for SharePoint (SPSS) console. 

Users are unable to access some SharePoint pages with error "Exception from HRESULT: 0x80041054".

The affected pages are temporarily recovered after SPE becomes online again and a full manual scan across the entire Sharepoint site (without any file exclusions).

However the same set of pages becomes unavailable again when SPE server becomes offline again on SPSS console.

 

 Error "Exception from HRESULT: 0x80041054" when users try to access certain SharePoint pages.

Cause

SPSS marked the problem pages with Virus Status 6 on the SharePoint site (AllDocs table) under MS-SQL database when SPE server becomes offline. However, the marking has not been cleared from the pages after SPE server recovered from offline although the problem SharePoint pages are available again.

If the Virus Status for a page was set to 6, following conditions will re-enable the user’s access to those pages but that will only be for the time being i.e. until the same scenario appears again where in SharePoint pages which have Virus Status set to 6.

  1. IISReset
  2. The virus definition of the SPE got updated.
  3. Disabling and enabling the ‘Scan documents on download’ on the Real-time scan settings page.

Resolution

The issue has been addressed on version 6.0.5. VirusStatus from problem SharePoint pages will be reverted from 6 to NULL automatically once SPE server becomes online on SPSS console.

(Please note: Installations and uninstallations of SPSS have to follow a sequence between Central Administration (CA) server and Web Front End (WFE) servers. Installation needs to be performed on CA first and on the WFE after whereas uninstallations needs to be done first on WFE and thereafter on CA. Same sequence applies to upgrade installation also.) 

To enable the fix, some additional steps are needed to enable the fix:

For clean installation of version 6.0.5:

a) Stop the "Symantec Protection 6.0 for SharePoint Server service" service on CA server first and followed by WFE servers.

b) Open the Symantec.Sharepoint.SPSSService.exe.config file from “InstallDirSharePoint” folder (e.g. C:\Program Files\Symantec\SharePoint).

c) Search for term "UpdateVirusStatus" and change the value from False to True.

d) Start the "Symantec Protection 6.0 for SharePoint Server service" service to apply the changes. The service needs to be started on CA server first and followed by WFE servers.

e) IISRESET needs to be performed on all the servers after the above steps are performed.

f) Take SPE servers offline by following one of the steps below:

  • Disable all the registered SPEs on one of the servers in the farm and re-enable it. (Preferable)
  • Delete all the registered SPEs on a server in the farm and re-register it.
  • Take all the SPEs offline from one of the servers in the farm and bring them online again. Taking an SPE offline means stopping the SPE service.

The first 2 options can be performed under "List and edit all registered Symantec Protection Engines" on SPSS console.

For version 6.0.5 which is upgraded from older version:

a) Stop the "Symantec Protection 6.0 for SharePoint Server service" service on CA server first and followed by WFE servers.

b) Open the Symantec.Sharepoint.SPSSService.exe.config file from “InstallDir\SharePoint” folder (e.g. C:\Program Files\Symantec\SharePoint).

c) Add the following lines below the <!--End TCP timeouts--> entry: 

<!--Start Update virusStatus field from 6 to null in case of time out or virus scanner unavailable-->

<add key="UpdateVirusStatus" value="True" /> 

d) Start the "Symantec Protection 6.0 for SharePoint Server service" service to apply the changes. The service needs to be started on CA server first and followed by WFE servers.
 
e) IISRESET needs to be performed on all the servers after the above steps are performed.
 
f) Take SPE servers offline by following one of the steps below:
  • Disable all the registered SPEs on one of the servers in the farm and re-enable it. (Preferable)
  • Delete all the registered SPEs on a server in the farm and re-register it.
  • Take all the SPEs offline from one of the servers in the farm and bring them online again. Taking an SPE offline means stopping the SPE service.

The first 2 options can be performed under "List and Edit all registered Symantec Protection Engines" on SPSS console.

 

 

 

Additional Information

To prevent SPSS from marking pages as Virus Status 6, it is also recommended to follow the steps from KB document 177620 to exclude certain file extensions from being scanned by SPSS.

For more information for different values for Virus Status field, see KB document 152971.