Replace a corrupt sem5.log
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Replace a corrupt sem5.log

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Article ID: 159266

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Updated On:

Products

Endpoint Protection

Issue/Introduction

  • Symantec Endpoint Protection Manager (SEPM) will not start due to database issues.
  • The Symantec Embedded Database service stops, with an assertion failure due to the transaction log, or hangs while attempting a recovery.

Cause

Possible corrupted database transaction log.

The following indications may be found in the err.log and out.log files located in the <SEPM Install Path>\db folder.

From err.log:

*** ERROR *** Assertion failed: 201129 (12.0.1.3554)[sem5]
File is shorter than expected

From out.log:

Database recovery in progress
    Last checkpoint at ...
    Checkpoint log...
    Transaction log: sem5.log...

*** ERROR *** Assertion failed: 201129 (12.0.1.3554)[sem5]
File is shorter than expected

Internal database error *** ERROR *** Assertion failed: 201129 (12.0.1.3554)[sem5]
File is shorter than expected-- transaction rolled back
Database server shutdown due to startup error

Resolution

  • Ensure the SEPM and SEPM Webserver services are stopped before attempting this process.
  • Stop the dbsrv<version>.exe process if it is still attempting recovery. (It will be hung in a starting state.)
    • To prevent the service from starting again, it may be necessary to adjust the service recovery options so that it does not immediately start again after you stop the process.
  • Open Windows Explorer to <SEPM Install Path>\db.
  • Rename sem5.log to sem5.old.log.
  • Open Windows Explorer to <SEPM Install Path>\ASA\win32.
  • Right-click on dbsrv<version>.exe and choose Run as Administrator.
  • In the server startup options, browse to <SEPM Install Path>\db and select sem5.db. (Note: The sem5.db shown after first clicking Browse is a default database, not the active one.)
  • In the Options field enter "-f", without quotes, and click OK.
    • The database application should start for a second, then quit.
  • Start the Symantec Embedded Database service and confirm a new sem5.log has been created in the <SEPM Install Path>\db folder.
  • Start the SEPM Webserver and SEPM services.

The file sem5.old.log may be deleted once you have confirmed that the issue with the transaction log has been resolved. If the service recovery options were altered, as stated above, please set them back now.

Version 14:

  1. Stop the Symantec Endpoint Protection Manager and Symantec Embedded Database services.
  2. Rename or delete the current sem5.log
  3. Click Start > Run and type CMD then click OK
  4. In the command prompt type:

    For 64-bit: CD C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\ASA\win64\ 
     
  5. Press Enter. This will change directories to the folder containing dbsrv16.exe.
    • To force the recreation of sem5.log, type:
       
    • For 64-bit: dbsrv16 -f "C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\db\sem5.db" 

      Note: There is no space between x and 86, and there is a space between -f and "
       
  6. Press Enter
  7. Start the following services:
    • Symantec Endpoint Protection Manager
    • Symantec Embedded Database