STPatchAssessment.log and STPatchAssessment.xml files found in the WindowsVulnerabilityScan folder on the NS.
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STPatchAssessment.log and STPatchAssessment.xml files found in the WindowsVulnerabilityScan folder on the NS.

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Article ID: 159330

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Updated On:

Products

Patch Management Solution

Issue/Introduction

Clients could not download and run the Patch Windows Assessment Scan Package.  The client logs showed that it was trying to download a file "STPatchAssessment.log" file that by default is not part of the package.  The Notification Server location, WindowsVulnerabilityScan folder, should only contain 5 files

Client Logs showed the following Warning and Error:

Process: AeXNSAgent.exe (7008)
Thread ID: 5496
Module: AeXNetComms.dll
Source: AeXNetworkTransport
Description: GetFiles 'HTTPS://NS_ServerName.com/Altiris/PackageShare/pkggroup_nneh5nkuy3ffad64acckm7raqewyoyae/
windowsvulnerabilityscan/STPatchAssessment.log'->'C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\
Software Delivery\6d417916-467c-46a7-a870-6d86d9345b61


Module: AeXNetComms.dll
Source: AeXNetworkTransport::Raw_GetFiles
Description: HTTP error: 404 Not Found (0x80042D21)

Environment

Patch Management 7.5 HotFix 6 and later

Cause

Customer had selected "Run from the server if bandwidth is above - Any connection speed" in the Symantec Management Agent Settings - Target (Settings > All Settings > Agents/Plug-ins > Symantec Management Agent > Settings > Symantec Management Agent Settings - Target > All Desktop computers (excluding 'Site Servers') > Download tab > Download and Run Options. 

This caused the client to run the Windows Assessment Scan from the SMP from the WindowsVulnerabilityScan folder on the Notification Server and created the scan / log files - STPatchAssessment.log and STPatchAssessment.xml. These files updated the Windows System Assessment Scan package and that new package needed to be replicated out to the clients; however, the updated package is invalid and will not download.

These files are regularly located at: <drive>://Program Files\Altiris\Altiris Agent\Agents\Software Management\Software Delivery\{6D417916-467C-46A7-A870-6D86D9345B61}\cache folder

Resolution

  1. De-select the "Run from the server if bandwidth is above - Any connection speed" option.  (Settings > All Settings > Agents/Plug-ins > Symantec Management Agent > Settings > Symantec Management Agent Settings - Target > All Desktop computers (excluding 'Site Servers') > Download tab > Download and Run Options. It is recommended this option be unchecked for any computer - desktop or server. 
  2. Delete the two files STPatchAssessment.log and STPatchAssessment.xml in the <drive>://Program Files/Altiris/Patch Management/Packages/WindowsVulnerabilityScan folder.
  3. Run the Scheduled Task NS.PackageRefresh to recreate the Snapshot for the package.
  4. Allow the clients to get an Updated Configuration request.