Discover scans fail. FileReader.log contains - SEVERE: Unmount Exception
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Discover scans fail. FileReader.log contains - SEVERE: Unmount Exception

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Article ID: 159453

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Updated On:

Products

Data Loss Prevention Network Discover Data Loss Prevention

Issue/Introduction

Discover scans fail with numerous Unknown Errors.

Cause

Also, if any sort of 3rd party backup is running on the volume then also the issue can occur.

Make sure no 3rd party backup is running on the volume.

Resolution

Issue:

Discover scans fail with numerous Unknown errors

FileReader.log contains:

SEVERE: Unmount Exception:
java.io.IOException: Unknown Error
at com.vontu.directorycrawler.VontuFileException.<init>(VontuFileException.java:160)
at com.vontu.directorycrawler.sharepointmapper.GenericSharePointMapper.unmapDrive(GenericSharePointMapper.java:311)
at com.vontu.directorycrawler.sharepointmapper.SharePointMapper.unmount(SharePointMapper.java:89)
at com.vontu.directorycrawler.AbstractFileSystemCrawler.unmountShareIfNecessary(AbstractFileSystemCrawler.java:267)
at com.vontu.directorycrawler.AbstractFileSystemCrawler.processContentRoot(AbstractFileSystemCrawler.java:212)
at com.vontu.directorycrawler.AbstractFileSystemCrawler.crawl(AbstractFileSystemCrawler.java:159)
at com.vontu.discover.crawler.AbstractCrawler$3.run(AbstractCrawler.java:113)
at java.lang.Thread.run(Unknown Source)
Jul 8, 2007 5:16:49 AM com.vontu.directorycrawler.AbstractFileSystemCrawler unmountShareIfNecessary
WARNING: failed to unmount:

and

INFO: Error output from umount command The device is being accessed by an active process.
More help is available by typing NET HELPMSG 2404.
Jul 8, 2007 5:16:09 AM com.vontu.directorycrawler.sharepointmapper.GenericSharePointMapper unmapDrive
WARNING: Could not identify command error condition!

Explanation:
Basically, two people can both remote desktop into a box and mount a share to l: without effecting each other. Each has a 'session'. Both can't mount 2 l: s in their own individual session. The Symantec DLP service basically maintains its own session and 'somehow' lost track of the unmount and therefore couldn't mount the new one.

Solution:
Restart the Symantec DLP Services and resume scan