Discover Scan fails with "Unknown Error"
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Discover Scan fails with "Unknown Error"

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Article ID: 160204

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Updated On:

Products

Data Loss Prevention Network Discover

Issue/Introduction

Discover scan gets the following error:

Unknown Error -- C:\Program Files\Symantec\DataLossPrevention\DetectionServer\15.x\Protect\bin>IF ""domain/username"" == """" (net use m: "\\hostname\share$" /persistent:no ) ELSE (net use m: "\\hostname\share$" <password> /user:"domain/username" /persistent:no )

Cause

This problem can occur when the "/" (forward slash) is used rather than the "\" (back slash) for domain\username value.  Please make sure that the discover target is using domain\username with a "\" (back slash).

Unknown Errors can be caused by several issues, where the above problem is a subset of them. The workaround is to disable the echo'ing of the smb.bat script due to a possible difference in how our software captures the data that is sent to standard out vs standard error. It looks like the standard out output is not capturing the error message properly.

Resolution

Turn off echo in the smb.bat script, add '@' in front of the net use command in the script.

If this does not resolve your issue, please contact Technical Support for further investigation and troubleshooting.