Performing a Discover scan with a Domain account results in errors.
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Performing a Discover scan with a Domain account results in errors.

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Article ID: 160228

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Updated On:

Products

Data Loss Prevention Network Discover Data Loss Prevention Discover Suite

Issue/Introduction

While attempting Discover scans using the JTDS driver, using a typical connection string with domain information results in failure to connect errors.

When specifying the credentials for the domain account (via "Use Saved Credentials" or "Use These Credentials"), the Symantec DLP Scan produces the following error:

"Unable to create a database connection: Unable to create connection: jdbc:jtds:sqlserver://sqlserver:1433/DatabaseName, Reason: Login failed for user 'domain\account'."

 

Environment

15.X, 16.X

Cause

If you are using a domain account for scanning SQL Server databases, the syntax of “<domain>\<username>” in the credentials field of the scan will not work.  This syntax will cause a login error on the scan. 

Resolution

In order to specify the domain, it must be included in the database connection string using the following syntax:

SQLSERVER://<server>:<port>/<database>;domain=<domain>

In the scan credentials field, you then must specify the domain user name without the domain qualification.