Unable to import solution pack due to following error “The Solution Pack install completed with errors. The database is in an inconsistent state.”
search cancel

Unable to import solution pack due to following error “The Solution Pack install completed with errors. The database is in an inconsistent state.”

book

Article ID: 160631

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

While importing a solution pack to newly installed Enforce server, it fails with the following error:

 

Mar 14, 2022 10:26:03 PM com.vontu.model.ojb.LockServerConnector logRemoteException
WARNING: Error performing registry lookup for lock server at 127.0.0.1:37328.
Mar 14, 2022 10:26:03 PM com.vontu.model.ojb.OJBLogger error
SEVERE: Error while commit objects, do abort tx org.apache.ojb.odmg.TransactionImpl@158a3b2e, Error performing registry lookup for lock server at 127.0.0.1:37328.
org.apache.ojb.broker.PersistenceBrokerException: Error performing registry lookup for lock server at 127.0.0.1:37328.
        at com.vontu.model.ojb.LockServerConnector.getLockServer(LockServerConnector.java:141)
        at com.vontu.model.ojb.OJBLockManager.getLockServer(OJBLockManager.java:96)
        at com.vontu.model.ojb.OJBLockManager.releaseLock(OJBLockManager.java:218)
        at org.apache.ojb.odmg.locking.LockManagerOdmgImpl.releaseLock(LockManagerOdmgImpl.java:93)
        at org.apache.ojb.odmg.TransactionImpl.doClose(TransactionImpl.java:439)
        at org.apache.ojb.odmg.TransactionImpl.commit(TransactionImpl.java:709)
        at com.vontu.model.ojb.OJBSystem.commitTransaction(OJBSystem.java:361)
        at com.vontu.model.ModelProxy.commitTransaction(ModelProxy.java:57)
        at com.vontu.model.notification.NotificationModel.commitTransaction(NotificationModel.java:171)
        at com.vontu.model.ModelProxy.commitTransaction(ModelProxy.java:57)
        at com.vontu.modeltransfer.LoadObjectFileHandlerDeserialize.loadToDataBase(LoadObjectFileHandlerDeserialize.java:454)
        at com.vontu.modeltransfer.LoadObjectFileHandlerDeserialize.loadObject(LoadObjectFileHandlerDeserialize.java:94)
        at com.vontu.modeltransfer.ImportObjectLoader.loadObjectFiles(ImportObjectLoader.java:99)
        at com.vontu.modeltransfer.Importer.importer(Importer.java:232)
        at com.vontu.modeltransfer.Importer.main(Importer.java:114)
Caused by: java.rmi.ConnectException: Connection refused to host: 127.0.0.1; nested exception is:

        java.net.ConnectException: Connection refused: connect
        at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:623)
        at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:216)
        at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:202)
        at sun.rmi.server.UnicastRef.newCall(UnicastRef.java:343)
        at sun.rmi.registry.RegistryImpl_Stub.lookup(RegistryImpl_Stub.java:116)
        at com.vontu.model.ojb.LockServerConnector.getLockServer(LockServerConnector.java:135)
        ... 14 more

 

Mar 14, 2022 10:26:04 PM com.vontu.model.notification.NotificationModel downConnection
SEVERE: Unable to connect to: com.vontu.model.ojb.OJBLockManager:127.0.0.1:37328

The Solution Pack install completed with errors. The database is in an inconsistent state.

 

Environment

DLP 15.8

Cause

SymantecDLPManagerService service was running due to which database connections were failing.

Resolution

1. Stop the SymantecDLPManagerService service from Service Manager(services.msc).

2. Open cmd as administrator, navigate to <DLP Install drive>\Program Files\Symantec\DataLossPrevention\EnforceServer\15.8.00000\protect\bin directory on the Enforce Server, this directory contains the SolutionPackInstaller.exe application.
Ex: cd C:\Program Files\Symantec\DataLossPrevention\EnforceServer\15.8.00000\protect\bin

3. Import the solution pack by running below command from the command line:
SolutionPackInstaller.exe import "C:\Program Files\Symantec\DataLossPrevention\Financial_v15.8.vsp"

4. Make sure that the installation succeeded without error.

5. Restart the SymantecDLPManagerService service.