Errors: ORA-22275, ORA-1652, ORA-01110, and ORA-00376 and the Enforce incident queue is backing up
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Errors: ORA-22275, ORA-1652, ORA-01110, and ORA-00376 and the Enforce incident queue is backing up

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Article ID: 160652

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Updated On:

Products

Data Loss Prevention Enforce Data Loss Prevention

Issue/Introduction

The Enforce incident queue is backing up.
You see the Errors: ORA-22275, ORA-1652, ORA-01110, and ORA-00376.

Cause

In general, a backlog is indicative of either slow processing due to a component, or the size of an incident, or a lack of resources.

Resolution

Relevant versions: ALL

  • Symptom:  Enforce Incident queue backlog increases after the disk has filled up and an additional disk was added.
  • alert_protect.log shows:  ORA-1652 : unable to extend temp segment by 4 in tablespace TEMP0
  • Incident.persister.log shows:  Caused by: java.sql.SQLException: ORA-22275: invalid LOB locator specified
    java.io.IOException: ORA-00376: file 203 cannot be read at this time 
    INFO | jvm 1 | 2007/07/09 14:40:16 | ORA-01110: data file 203: '/u01/oracle/protect/datafiles/temp0.dbf' 

Resolution:

  1. Check the status of .dbfs using sqlplus as sysdba:
    1. SELECT file#,name,status,enabled from v$tempfile;
  2. If TEMP0 shows offline, you will need to bring it back online. To bring it online:
    1. ALTER database datafile <full_path_datafile_name> online;
    2. Example:  ALTER database datafile /u01/oracle/protect/datafiles/temp0.dbf' online;
  3. Then stop the SymantecDLP services on Enforce Manager.
  4. Stop and restart DB and Listener.
  5. Restart the SymantecDLP services on the Enforce Manager.
  6. Verify that the Incident queue decreases