Indexing was unsuccessful error during initial indexing of IDM
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Indexing was unsuccessful error during initial indexing of IDM

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Article ID: 160663

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Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

During creation of IDM profile, error occurs:

Error: Indexing was unsuccessful. Check the log files for details

Logs for tomcat include error such as the following:

26 May 2012 01:57:25,784- Thread: 35 SEVERE [com.vontu.profiles.manager.InfoSourceIndexCreator] Error during document indexing
Cause:
java.lang.RuntimeException: java.security.AccessControlException: access denied (java.lang.RuntimePermission modifyThread)
java.security.AccessControlException: access denied (java.lang.RuntimePermission modifyThread)
java.lang.RuntimeException: java.security.AccessControlException: access denied (java.lang.RuntimePermission modifyThread)

Resolution

Firstly, confirm 'protect' user has Read access to the IDM source directory.

If this seems correct, it may be a matter of a lost database connection. Try restarting all Symantec Data Loss Prevention services on the Enforce server, then re-attempt indexing.

If indexing still fails, a full reboot of the server should resolve the issue.