Unable to import a Solution Pack. Database is not empty error
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Unable to import a Solution Pack. Database is not empty error

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Article ID: 160805

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Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

The user trying to import a solution pack and the import failed after a few seconds.

Error:

Database is not empty: CommandInfo

 

Also may be:

Database is not empty: Role

Cause

The user is trying to import a solution pack to a Database that is not empty.

Resolution

As per Symantec DLP Installation Guide, the import of a solution pack must be performed right after the initial installation, without any Detection Server installed.
 
There can be no Detection Servers, policies, additional users or roles added.  The Solution Pack must be installed before anything else. 

If you wish to install a Solution Pack after the database has been used, it must be cleared.  Reinstall the Enforce Server and select the Initialize Enforce Data option.  This will recreate the database, removing anything previously added, including incidents.