Symantec Protection for SharePoint Servers (SPSS) service crashed due to corrupted xml and/or dat settings files.
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Symantec Protection for SharePoint Servers (SPSS) service crashed due to corrupted xml and/or dat settings files.

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Article ID: 161676

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Updated On:

Products

Protection for SharePoint Servers

Issue/Introduction

SPSS service crashed and SharePoint pages become inaccessible.

Some files with either xml/dat format under the following folders are getting corrupted or become zero bytes:

  • <Installdir>\Program Files\Common Files\Symantec Shared\SharePointEngine\
  • <Installdir>\Program Files\Common Files\Symantec Shared\SharePointEngine\SEMaster\

Errors will also be observed under Windows Application Event log.

 

Event ID 0 will be observed under Windows Application Event log with the following error:

Module=LoadBalancer/Service.seStatusWatcher_Changed | Exception message=There is an error in XML document (0, 0). | Inner exception message=Root element is missing. | Stack=   at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)

   at Symantec.Sharepoint.LoadBalancer.Service.seStatusWatcher_Changed(Object sender, FileSystemEventArgs e)

 

 

Cause

Deadlock situation encountered due to the file handling case in multithreading scenario. Issue occurs if thread exists without releasing the file handle.

Resolution

Symantec is aware of this issue and will update this document when a solution becomes available. It may not be necessary to log a support case on this issue. Please subscribe to this article to be notified of any updates.

Workaround:

As the issue is due to file handling, different scenarios may be observed since different softwares may be installed in different environments. However, Symantec recommends desktop antivirus scanning exclusion should at least be performed on all servers with SPSS installed. The following folders should be excluded from antivirus scanning:

  • <Installdir>\Program Files\Symantec\SharePoint\
  • <Installdir>\Program Files\Common Files\Symantec Shared\

If the issue still re-occurs with desktop antivirus scanning exclusion has been configured on the above folders, all zero bytes xml files should be replaced with the same files present on another server within the same SharePoint farm from the same location (<Installdir>\Program Files\Common Files\Symantec Shared\SharePointEngine\).

However there are exceptions on the followings:

  • “ReportSchedule.xml” file from the above location cannot be replaced with the one from another server within the same SharePoint farm. Instead the file should be replaced from the attached default “ReportSchedule.xml” file. Replacing this file will delete all the scheduled reports that were created on this server.
  • If the “AVESettings_<IPAddress>” or “AVEStatistics_<IPAddress>” at the above location gets corrupted or becomes zero bytes, the “AVEInformation.dat” file at the location “<Installdir>\Program Files\Common Files\Symantec Shared\SharePointEngine\SEMaster” should be replaced with the default template attached.
  • If the “AVEInformation.dat” file at the location “<Installdir>\Program Files\Common Files\Symantec Shared\SharePointEngine\SEMaster” gets corrupted or became zero bytes, the file should be replaced with the attached default template. Replacing the file will delete all the Symantec Protection Engine(s) which were registered on this server.

 

 


Applies To

SPSS 6.0.5 or lower

Attachments

ReportSchedule.xml get_app
AVEInformation.dat get_app