Rollback fails after upgrade failure of Security Virtual Appliance (SVA) extension.
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Rollback fails after upgrade failure of Security Virtual Appliance (SVA) extension.

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Article ID: 161734

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Updated On:

Products

Data Center Security Server Data Center Security Server Advanced

Issue/Introduction

Rollback fails after upgrade failure of Security Virtual Appliance (SVA) extension.

 

Execute the following commands from an Administrative command prompt to see if SVA Extension is in inconsistent state:

1.      “sc query symantectoasterservice” returns error 1060 (Specified service does not exists).

2.      “fltmc” does not show virtual agent driver entry (VirtualAgent).

 

Cause

Root cause:
In upgrade case the sequence of installation is as below:

If we are upgrading from 6.5.0 to 6.5.1 then,
(1) installer will detect its upgrade condition.
(2) installer will un-install 6.5.0 from system.
(3) installer will install 6.5.1 on system.

if step-2 or step-3 fails in present installer, installer does not roll back to
6.5.0

 

Resolution

To Resolve:

  1. Uninstall the SVA Extension either thorough control panel or command line.

1.1  To uninstall from control panel, go to Add or remove programs / Uninstall a program , uninstall the SVA Extension.

1.1.1        If Quarantine folder is not empty, then a dialog will be displayed with message “Do you want to delete the Quarantine folder and all the files within the folder? Click Yes or No.”.

1.1.2        Click No to keep the Quarantine folder files.

1.2   To uninstall from command line, Run the command “SVAExtension.exe /quiet /uninstall DELQUAR=NO”.

 

  1. Install newer version of  SVA Extension.