How to increase the number of CCS Application Server Log files.
search cancel

How to increase the number of CCS Application Server Log files.

book

Article ID: 162310

calendar_today

Updated On:

Products

Control Compliance Suite Control Compliance Suite Standards Module Control Compliance Suite Standards Server

Issue/Introduction

You need to increase the number of log files on the Application Server as there is too much being logged and information is being overwritten.

The number of the Application Server log files that are created by default was typically not enough for Development to determine problems, as so much information is logged that by the time the job finished, the information in the logs was overwritten and lost.  

Environment

CCS 12.6.x

Cause

As per the recommendation from CCS Development, the amount and size of the files for logging should be increased permanently.

Resolution

This can be done via some modifications in the AppserverService.exe.config file on the CCS Application Server. Perform the following steps.

  1. Close the CCS Console.
  2. Stop the Symantec Application Server Service.
  3. Go to the following location-<Install Dir>:\Program Files (x86)\Symantec\CCS\Reporting and Analytics\Application Server
  4. Find the AppserverService.exe.config file and open in it Notepad/Wordpad.
    • Note make a backup of AppserverService.exe.config file before modifying it.
  5. Now, go to the <logging> section and at the end of that logging section add the following two keys-
    • <add key="Log.FileLogger.MaxHistoricalLogfileSize_MB" value="100" />
    • <add key="Log.FileLogger.MaxHistoricalLogfileCount" value="10" />

      (This will allow the Application Server to create 10 App Server Log files of 100 MB each before overwriting the oldest log file)
  6. Save the AppserverService.exe.config file and restart the Application Server Service.