Unable to edit an existing or new 'Editable data class'
search cancel

Unable to edit an existing or new 'Editable data class'

book

Article ID: 162408

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

When creating a new "Editable data class" by going to Settings > Notification Server > Resource and Data Class Settings > Data Classes > [user defined folder], and then right-clicking the folder and selecting "New > Editable Data Class", There are no options to edit the data class after creating it.


This is how it should look like when it is working:

 

Cause

In order to edit these 'Editable Data Classes', you need to have CMDB/Asset Solutions installed.
As you can see from the screenshot above, the customer doesn't. Otherwise he will have a folder called 'CMDB Data Classes' under Settings > Notification Server > Resource and Data Class Settings > Data Classes. CMDB and Asset Solutions were flagged as un-installed in the database even though those same Solutions are installed under SIM.

Resolution

In order to validate that this issue is the same with having these Solutions as flagged as un-installed in the database:

1. Please run the following query:

--Find all solutions that are currently set to uninstalled
select distinct i2.Guid, i2.Name, cast (i2.state as xml).value ('(/item/version)[1]', 'nvarchar(100)') as 'Version'
from Item i
join Item i2 on i2.Guid = i.ProductGuid
where i.ProductUninstalled = 1
order by 3

You should see the following Products/GUIDs under the result section flagged as un-installed:

22506AFA-1F15-4728-93CB-32E6F26DDD34    Altiris Asset Management Solution 
AE83A505-FFE2-4188-A0ED-D15F994FEB12    Altiris CMDB Solution 

2. In order to fix this, you will need to re-install CMDB and Asset Solutions via SIM.