When Workflow application is republished, it will not retain its previous Application Pool.
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When Workflow application is republished, it will not retain its previous Application Pool.

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Article ID: 162443

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Updated On:

Products

Workflow Solution

Issue/Introduction

When Workflow application is republished, it will not retain its previous Application Pool. This may be problematic when specific Application Pool is desired for security, separation or performance reasons.

Cause

Design change in Workflow 7.6. After reviewing the behaviour, it was decided to change this back to previous way.

Resolution

This issue has been fixed in Workflow 7.6 Rollup (build 7.6.4383.496 and newer). See INFO2509 for a list of fixed issues in Rollup. To acquire the roll-up please contact Symantec Technical Support and reference this article or the Rollup article.

A workaround exists in the form of clearing out the App Pool Id field in Deployment Info settings.

  1. Start LocalMachineInfo Editor tool
  2. In Workflow Server section, click ellipsis '...' button next to Workflow Server Configuration setting
  3. In dialog that opens, in Deployment section click ellipsis '...' button next to Deployment Info setting
  4. Clear the App Pool Id field (do not select an application pool just delete what is in the field)