Getting error "Failed to parse product listing XML. Element 'linkText' is empty (has no child elements))".
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Getting error "Failed to parse product listing XML. Element 'linkText' is empty (has no child elements))".

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Article ID: 162527

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Updated On:

Products

Client Management Suite IT Management Suite Server Management Suite

Issue/Introduction

When launching SIM (Symantec Installation Manager), the following popup window is displayed:

(The product listing located at http://solutionsam.com/solutions/pl/symantec_v2.pl.xml.zip could not be accessed.)

If you click 'Cancel' on the message, the following popup window is displayed:

(Symantec Installation Manager failed to initialize. See log for details).

When you look at the SIM Install logs, the following errors are present:

Entry 1:
Failed to parse product listing XML from file 'D:\Program Files\Altiris\Symantec Installation Manager\InstallHistoryPl.xml'.
Element 'linkText' is empty (has no child elements).
   [Symantec.Installation.Xml.XmlValidationException @ SimXmlParser]
   at Symantec.Installation.Xml.Reader.GetProductLinks(XmlReader xmlReader, PartialProductListing partialProductListing)
   at Symantec.Installation.Xml.Reader.GetProductData(PartialProductListing partialProductListing, XmlReader xmlReader)
   at Symantec.Installation.Xml.Reader.ReadProducts(XmlReader xmlReader, PartialProductListing partialProductListing)
   at Symantec.Installation.Xml.Reader.ReadProductListingXml(XmlReader xmlReader, XmlReader plLangReader)
   at Symantec.Installation.Xml.Reader.ReadXml()
   at Symantec.Installation.Managers.ProductListingManager.ReadProductListingFile(String productListingFile, String productListingLanguageFile, ProcessorType filterPlatform)
-----------------------------------------------------------------------------------------------------
Date: 10/23/2015 11:01:38 AM, Tick Count: 323536775 (3.17:52:16.7750000), Size: 2.54 KB
Process: SymantecInstallationManager (9896), Thread ID: 9, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Managers.ProductListingManager.ReadProductListingFile

 

Entry 2:
Failed to load Install History Product Listing Xml file 'D:\Program Files\Altiris\Symantec Installation Manager\InstallHistoryPl.xml'.
-----------------------------------------------------------------------------------------------------
Date: 10/23/2015 11:01:38 AM, Tick Count: 323536775 (3.17:52:16.7750000), Size: 444 B
Process: SymantecInstallationManager (9896), Thread ID: 9, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Managers.ProductListingManager.LoadProductListingData

Cause

Possible corruption of the InstallHistoryPl.xml (under ...\Program Files\Altiris\Symantec Installation Manager).

After looking at this closer the InstallHistoryPl.xml was missing a tag for the attribute <linkText> in one of the products. 
When  it is broken, the following entry line looks like this:

<links>
                <link>
                    <url>http://community.biomni.com/</url>
                    <linkText stringId="{DCE2C69D-705D-4EC8-A38E-32A07B1B6374}" />
                </link>
</links> 

Resolution

In order to fix this issue:

  1. Open the InstallHistoryPl.xml (under ...\Program Files\Altiris\Symantec Installation Manager).
  2. Look for any opening <linkText> without a closing tag. For example:
     <linkText stringId="{DCE2C69D-705D-4EC8-A38E-32A07B1B6374}" />
  3. Add the the proper opening and closing tags:
    <linkText stringId="{DCE2C69D-705D-4EC8-A38E-32A07B1B6374}">Front Office Community</linkText>
  4. Save the file.
  5. Launch SIM one more time.