Reinstalling Symantec Management Agent on Notification Server
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Reinstalling Symantec Management Agent on Notification Server

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Article ID: 162647

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Updated On:

Products

IT Management Suite

Issue/Introduction

Need to downgrade Symantec Management Agent from a newer to older version on the Notification Server. Agent has been upgraded after accidentally switching to a different Notification Server that has a newer version.

Errors in the SMA log files:

 

<event date='11/26/2015 07:37:41.2980000 +00:00' severity='1' hostname='<SERVER_NAME>.<YOUR DOMAIN>' source='NetworkOperation' module='AeXNetComms.dll' process='AeXNSAgent.exe' pid='2088' thread='7804' tickCount='2266335' >
  <![CDATA[Operation 'Connect' failed.
Protocol: HTTPS
Host: <SERVER_NAME>.<YOUR DOMAIN>:443
Path: /
Http status: 0
Id: {xxxxxxxxx-A5AD-4AE6-A2E1-23F854A06164}
Error type: DNS error
Error result: 0x80072AF9
Error code: 0
Error note: Failed to resolve FQDN and short name to IP address
Error message: No such host is known]]>
</event>
<event date='11/26/2015 07:37:41.2980000 +00:00' severity='2' hostName='SERVER_NAME' source='ConfigServer' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='2088' thread='7804' tickCount='2266335' >
  <![CDATA[Failed to send data to 'HTTPS://<SERVER_NAME>.<YOUR DOMAIN>:443/Altiris/NS/Agent/CreateResource.aspx?nsversion=1', COM error: No such host is known (0x80072AF9)]]>
</event>
<event date='11/26/2015 07:37:41.2980000 +00:00' severity='1' hostName='SERVER_NAME' source='ConfigServer' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='2088' thread='7804' tickCount='2266335' >
  <![CDATA[Configure Server Mode: Failed to receive server version from '<SERVER_NAME>.<YOUR DOMAIN>']]>
</event>
<event date='11/26/2015 07:37:41.2980000 +00:00' severity='2' hostName='SERVER_NAME' source='Agent' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='2088' thread='7804' tickCount='2266335' >
  <![CDATA[Agent registration failed, current status 'Not registered'. Next retry in 1 min.]]>

 

Environment

ITMS 7.x, 8.x

Cause

SMA cannot find NS version number.
 

Resolution

In this case the Agent has to be re-installed. Steps to follow:

(1) uninstall the Symantec Management Agent;

Open command prompt and navigate to folder (by default) 'C:\Program Files\Altiris\Altiris Agent' and execute following command: 'AeXNSAgent.exe /uninstall'

This will remove the Agent.

(2) install correct version of the Agent;

To install SMA, please refer to our Online Help documentation

After completing installation make sure the SMA on the Notification Server is registered to itself (to NS).

 

It may be also necessary to run Task Server repair. To do this follow one of the methods below:

 

Method 1:

Open Symantec Installation Manager and run Symantec Management Platform repair (e.g. Symantec Management Platform 7.5 SP1). Repair Any current hotfixes: If the SMP is on 7.5.x hotfix then go through SIM and run a repair on the Symantec Management Platform hotfix.

 

Method 2:

On the Notification Server, go to (by default) 'C:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris' folder and execute from the commandline following MSI:

(1) msiexec /i altiris_taskmanagement_7_5_sp1_x64.msi SKIPAIM=1

(2) msiexec /i altiris_taskserversetup_7_5_sp1_x64.msi SKIPAIM=1

(3) msiexec /i altiris_taskservertasks_7_5_sp1_x64.msi SKIPAIM=1

Repair Any current hotfixes: If the SMP is on 7.5.x hotfix then go through SIM and run a repair on the Symantec Management Platform hotfix.