Symantec Mail Security for Microsoft Exchange 7.5.1 and earlier will no longer be able to utilize version 4 (v4) Rapid Release (RR) or Intelligent Updater (IU) definition packages after April 15th, 2016.
search cancel

Symantec Mail Security for Microsoft Exchange 7.5.1 and earlier will no longer be able to utilize version 4 (v4) Rapid Release (RR) or Intelligent Updater (IU) definition packages after April 15th, 2016.

book

Article ID: 162702

calendar_today

Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

 

Symantec Mail Security for Microsoft Exchange (SMSMSE) 7.5.1 and earlier versions no longer update via Rapid Release definitions as of April 15th, 2016.

Cause

For protection against the latest known mail-bourne threats, the use of Rapid Release definitions is recommended at the mail server rather than just the default certified definitions.

If Rapid Release definitions are to be used, older versions of SMSMSE must be updated to use version 5 virus definitions.  Symantec is no longer publishing version 4 virus definitions.

Resolution

Upgrade to Symantec Mail Security for Microsoft Exchange 7.5.2 or later.  If this is not immediately possible, please apply the workaround, below.

 

Workaround

Apply the attached hotfix. 

Applicable versions:

  • 7.5.0 and 7.5.1
  • 7.0.0 to 7.0.4
  • 6.5.0 to 6.5.8

This patch is not applicable to:

  • 7.5.2 or later.  7.5.2 and later are already compatible with v5 packages.
  • The Intelligent Updater (IU) or Rapid Release (RR) definitions are not being used to update the definitions for SMSMSE.

 

Prerequisite

Install the Microsoft Visual C++ 2010 x86 runtime redistributable
 

 

Steps to apply the patch

This utility will automatically create the registry keys necessary to run the v5 Intelligent Updater, and update the Rapid Release scripts to download the v5 intelligent updater.

  1.  Download and extract RR_IU_UPDATE.ZIP attached to this article.
  2. Login to SMSMSE server using the same credentials that you have used to install SMSMSE.
  3. Copy “SMSMSEAuth.dll”, “SMSMSEDefUDply.dll” and “SMSMSERRDefUpdate.exe” at location “<InstallDir>\Symantec\SMSMSE\<Version>\Server”.
  4. Open a command prompt as administrator.
  5. Run the command cd <installdir>\Symantec\SMSMSE\<Version>\Server.
  6. Run the Command  SMSMSERRDefUpdate –install
  7.  Open the services console and restart the Symantec Mail Security for Microsoft Exchange service.

To test whether the patch applied successfully

Rapid Release (RR)

1.   Open SMSMSE Console.

2.   Navigate to Admin>LiveUpdate/Rapid Release Status

3.   Click "Run Rapid Release Definitions (via FTP)

 

Intelligent Updater (IU)

1.   Download latest V5 definitions set “<Date-rev>-core15v5i32.exe” from following location:    

ftp://ftp.symantec.com/public/english_us_canada/antivirus_definitions/norton_antivirus_corp/ or http://www.symantec.com/business/security_response/definitions/download/detail.jsp?gid=gw

2.   Copy downloaded V5 definitions set to location“<InstallDir>\SMSMSE\<Version>\Server”.

3.   Run following command from windows command prompt:

"<Date-rev>-core15v5i32.exe /Extract VIRSCAN.zip "C:\ProgramData\Symantec\Definitions\SymcData\VirusDefs32\incoming" 

4.   Verify the the definitions are consumed by SMSMSE.  It may take several minutes for the Console to display the new date.

 

Manual Installation Process

The steps describe the actions taken by the attached utility. These steps may be used in the event the patch fails to run successfully.

1.    Login to SMSMSE server using the same credentials used to install SMSMSE.
2.    Copy “SMSMSEAuth.dll” , “SMSMSEDefUDply.dll” and “SMSMSERRDefUpdate.exe” at location “<InstallDir>SMSMSE\<Version>\Server”.
3.    Create following registry Key and Value at location:


 [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Symantec\IntelligentUpdater\LocalDLLs]

  • SMSMSEIUAuth=<install_location>\SMSMSEAuth.dll
  • SMSMSEIUDeploy=<install_location>\SMSMSEDefUDply.dll

4.    In “<InstallDir>SMSMSE\<Version>\Server” create backup copy of files “RapidReleasex64.bat” and “RR64” file.
5.    Modify “RR64” with the following changes:


For SMSMSE v6.5.x, 7.0.x, v7.5.0
“symrapidreleasedefsi64.exe” to “symrapidreleasedefscore15-v5i32.exe”


For SMSMSE v7.5.1
“symrapidreleasedefscore15-i64.exe” to “symrapidreleasedefscore15-v5i32.exe”

6.    Modify “RapidReleasex64.bat” with the following changes:


For SMSMSE v6.5.x, 7.0.x, v7.5.0
“symrapidreleasedefsi64.exe” to “symrapidreleasedefscore15-v5i32.exe”


For SMSMSE v7.5.1
“symrapidreleasedefscore15-i64.exe” to “symrapidreleasedefscore15-v5i32.exe”

7.    Rename SMSMSERRDefUpdate.exe:


For SMSMSE v6.5.x, 7.0.x, v7.5.0
“SMSMSERRDefUpdate.exe” to “symrapidreleasedefsi64.exe”


For SMSMSE v7.5.1
“SMSMSERRDefUpdate.exe” to “symrapidreleasedefscore15-i64.exe”

 

8.   Restart SMSMSE Services

-    Symantec Mail Security for Microsoft Exchange
-    Symantec Mail Security Utility Service

 

 

Attachments

RR_IU_UPDATE.zip get_app