Symantec Installation Manager fails to install or upgrade products - File hash does not match reference hash
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Symantec Installation Manager fails to install or upgrade products - File hash does not match reference hash

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Article ID: 162890

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Updated On:

Products

IT Management Suite

Issue/Introduction

When trying to install or upgrade a product from inside the Symantec Installation Manager it will fail and say 'The following files have failed to validate'. The window that pops up with the error message will list a number of msi files that failed to install.
 

[1] 1/27/2016 11:31:31 AM (SymantecInstallationManager) Symantec.Installation.FileValidator.ValidateFile
Failed to validate file 'D:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris\altiris_softwaremanagementframework_7_5_sp1_hf5_x64.msi' File hash does not match: reference hash: e72a48d413c7cb7b967f32daeddd7ea51160e028928b3542198653aa5fb6c6e8/computed hash: 632db8892bb9e5fd7cc6273db1025207be641e79b3506ee22bcf964142cea1de

[1] 1/27/2016 11:31:31 AM (SymantecInstallationManager) Symantec.Installation.FileValidator.ValidateFile
Failed to validate file 'D:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris\altiris_ppaagentsolution_7_5_sp1_hf5_x64.msi' File hash does not match: reference hash: 3e76addd931a900ba778fa772a50b8b2a883b23e0ba23d65b5a96f7f1d3e1aeb/computed hash: 4b46e09df3f1f9e184a291026048803232018f5e12e6078323f079a8bc2ab990

[1] 1/27/2016 11:31:31 AM (SymantecInstallationManager) Symantec.Installation.FileValidator.ValidateFile
Failed to validate file 'D:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris\altiris_softwaremanagementsolution_7_5_sp1_hf5_x64.msi' File hash does not match: reference hash: 23c13e4f91cd9a93350109786dac0e6e8755a0122cd5f90dba51ede8c6194054/computed hash: 9f81e0222270d8a16c576e35977512cdff5fd191dc3296f53ce6f90d0f272261

[1] 1/27/2016 11:31:31 AM (SymantecInstallationManager) Symantec.Installation.Context.WizardProcess.DownloadManager.FileValidationComplete
The following files have failed to validate: 
http://www.solutionsam.com/solutions/7_5_sp1_hf5/smp/altiris_softwaremanagementframework_7_5_sp1_hf5_x64.msi?symct=1453915198_7a105ce4503323fe7398f21481b6083f
http://www.solutionsam.com/solutions/7_5_sp1_hf5/smp/altiris_ppaagentsolution_7_5_sp1_hf5_x64.msi?symct=1453915198_015b354b242ccb786c0fd15334f833f8
http://www.solutionsam.com/solutions/7_5_sp1_hf5/sms/altiris_softwaremanagementsolution_7_5_sp1_hf5_x64.msi?symct=1453915199_930e0e0680823e3736cc98841b8e779b
 

Environment

ITMS 7.0 and later
 

Cause

In one situation a customer had Juniper firewall that had AntiVirus scanning turned on for files that would download on the server and this was causing the downloads to fail.

In another situation the downloaded installation files were corrupted and needed to be replaced manually.

In another situation, it was caused because the server time and date was wrong.

Resolution

Scenario 1:
1. Start an upgrade or installation in SIM that fails with errors about MSI files not validating

2. Open the Altiris Log Viewer and find the logs for one of the packages that was failing. Then copy the download URL for the package and open it in a browser on the NS.
* Example: http://www.solutionsam.com/solutions/7_6_hf7/smp/altiris_taskmanagement_7_6_hf7_x64.msi?symct=1454097469_064fc464632d73ae76676071883a0a9a 

3. If the download succeeds take the new file and replace the old file in the Installs directory (usually C:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris) then try the install/upgrade again. 

4. If the URL fails and throws an error that says 'Download request is dropped due to exceeding max decompress layer limit' try using the same url on a different computer that is not subject to the same firewall/antivirus. If it succeeds the hash can be checked using SHA256hash.exe to make sure it matches the reference hash from the logs.

5. Either transfer the file to the install directory on the NS or disable the firewall rule preventing the download on the NS and run the install/upgrade again.

 

Scenario 2:

Check that your server doesn't have the wrong date or time (like the date is on the past or in the future, OR the time is off by 15 minutes or more). If it is, change it to match the correct one.

Attachments

sha256hash.zip get_app