Subnets are being created from inventory which causes problems with site assignment and package download
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Subnets are being created from inventory which causes problems with site assignment and package download

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Article ID: 162904

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Updated On:

Products

Client Management Suite IT Management Suite Software Management Solution Deployment Solution

Issue/Introduction

Mystery subnets, some supernets, keep showing up in the list of subnets under “Settings > Notification Server > Site Server Settings > Subnets.  Supernets usually happens when a system Admin puts an incorrect Subnet Mask on a test system and then inventory runs.

The subnets often contain wide open masks which encompass other subnets into them causing confusion about why clients are getting packages from package servers they are not supposed to be getting packages from. Also, they are connecting to Task Servers they should not be connecting to.

Common supernets are 10.0.0.0/8 and 172.0.0.0/8, but can be created from any subnet when an incorrect Mask is used.

Cause

There is a task called “Subnet Resource Creation Schedule” which runs every day with the “Package Refresh” shared schedule (default is 3:30am). This task creates subnets from basic inventory submitted by clients—if the subnets do not exist.  It is sometimes useful, but can cause problems in systems where the administrators would prefer creating subnets themselves, or importing them from AD.

To find possible supernets:

select *
from Inv_AeX_AC_TCPIP ip
where ip.[Subnet Mask] like '255.0%'

select *
from inv_subnet
where [Subnet Mask] like '255.0.%'

select Subnet, [Subnet Mask], count(*) as ComputersOnSubnet
from Inv_Subnet
group by Subnet, [Subnet Mask]
order by 2 

Resolution

The  “Subnet Resource Creation Schedule” task can be disabled from running by removing it from running within the “Package Refresh”  shared schedule. Disabling this schedule will stop Inventory data from populating Subnets.

If this is desired run the following SQL against the database using “Microsoft SQL Server Management Studio”.

 

Delete from ItemSchedule WHERE ItemGuid = '94FA536C-885C-4B73-92DE-BB49A7F0244E'

 

UPDATE Item SET [State] = replace(cast([State] as nvarchar(max)),

                '<enabled>True</enabled>',

                '<enabled>False</enabled>'),

                ModifiedDate = getdate()

WHERE Guid = '94FA536C-885C-4B73-92DE-BB49A7F0244E'

 

UPDATE Item SET [State] = replace(cast([State] as nvarchar(max)),

                '<sharedSchedule>{bd6bf880-bfae-4dad-b746-e8be99f3b8a8}</sharedSchedule>',

                '<sharedSchedule>{00000000-0000-0000-0000-000000000000}</sharedSchedule>'),

                ModifiedDate = getdate()

WHERE Guid = '94FA536C-885C-4B73-92DE-BB49A7F0244E'