Ghost clients are not responsive and or tasks are not executing jobs.
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Ghost clients are not responsive and or tasks are not executing jobs.

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Article ID: 162966

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Updated On:

Products

Deployment Solution

Issue/Introduction

Computers in the console connect sporadically, a few symptoms are listed below

1. The job cannot be started, and errors out.

2. Computers are unresponsive or do not connect to the console.

3. Dagent cannot update.

4. Cannot re-configure machines from the console.

5. Dagent doesn't initialize in automation.

6. Initial deployment menu never appears in automation.

Common errors seen are "Failure to transfer package" and no connectivity from the client machines.

Environment

ITMS 8.x

Deployment Solution 8.x

Cause

The Ghost client is Dagent and this behavior can be caused by using encrypted sessions on Dagent Communication.

Resolution

Turning off encrypted sessions normally resolves this issue, please follow the steps below.

Altiris Deployment Server

Navigate to Control Panel -> Altiris Deployment Server -> Options -> Transport and deselect "Allow Encrypted Sessions" . Select "Ok" and restart the service from the service control pane in the Altiris Deployment Server menu.

If clients are currently installed using encrypted sessions, there are a few options for fixing this.

1. Physically modify the Dagent settings on the client PC by opening the Dagent configuration utility, unchecking "Encrypt Session Communication..." under 'Security' Tab

2 Navigate to the Service Control tab and restart Dagent services

OR

1. Using Remote Agent Install, reinstall the agent on all machines that were installed using session encryption. Make sure to uncheck encrypted sessions when modifying the remote install agent settings by selecting "Change Settings"

Alternatively, you can modify the registry keys on the server as follows:

[HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Client Service]
"EncryptSessions"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Altiris\Altiris eXpress\Options]
"EncryptionSupport"=dword:00000000

[HKEY_USERS\S-1-5-21-2527420752-3334223218-1834775913-500\Software\Altiris\Remote Client Installer\Settings\Client Settings]
"EncryptSessions"=dword:00000000

[HKEY_CURRENT_USER\Software\Altiris\Remote Client Installer\Settings\Client Settings]
"EncryptSessions"=dword:00000000

Attachments

DisableEncryptedSession.reg get_app