"Output @errorMessage=The Exception have occured in Client Imaging Task" in DStasks.log when capturing an image to a site server
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"Output @errorMessage=The Exception have occured in Client Imaging Task" in DStasks.log when capturing an image to a site server

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Article ID: 163013

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Updated On:

Products

Deployment Solution

Issue/Introduction

The following error is shown in the DStasks.log file when trying to capture an image to a site server

Output @errorMessage=The Exception have occured in Client Imaging Task.

Exception has occured in function SMPPackage.cpp() at Line No 233. Type of exception is GeneralError. Error is callDSPSInfoOperationService()have failed.

Output @errorMessage=The Exception have occured in Client Imaging Task.

Exception has occured in function SMPPackage.cpp() at Line No 233. Type of exception is GeneralError. Error is callDSPSInfoOperationService()have failed.

Cause

This is a rights issue

Resolution

To troubleshoot this issue do the following:

  1. Open IIS and browse to the 'altiris> PS' site.
  2. Verify that the 'Deployment' website is present
    1. If the deployment website is not present go to <drive>\program files\altiris\altiris agent\agents and verify that the Deployment folder is present. If it is not present run the Deployment Package Server Components package. (dsps)
    2. If the deployment webiste is stil not present after manually running the DSPS install, manually create the deployment app and point to the path in step 1
  3. Click on the 'Deployment' site
  4. In the features view open the authentication view
  5. Verify that the proper authentication is used.  E.g. Digest should be enable if the AppID is a domain account; Basic Authentication should be enabled if the AppID is a local account.  Note:  If you have a system that is a member of a domain but is using a local admin account for the Symantec Services (appID), the DSPS installer will enable Digest authentication.  In this situation disable digest authentication and enable Basic Authentication
  6. Open a command prompt and type 'iisreset'
  7. Boot into automation and attempt to create an image
  8. If an error still occurs, open IIS again and go back to the Authentication view.
  9. Double click on 'ASP.NET Impersonation' and click 'edit' in the far right pane
  10. Select the radio button next to 'specific user'
  11. Click on the 'SET' button
  12. Enter the username that the local Symantec services are using
  13. Open a command prompt and type 'iisreset"
  14. Boot into automation and attempt to create an image

 

Note: This error is always a rights issue. If the steps above do not resolve the issue please contact support for further assistance.