Agent Health is not working correctly for any computers
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Agent Health is not working correctly for any computers

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Article ID: 163171

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Updated On:

Products

IT Management Suite

Issue/Introduction

All computers show a grey icon for the health status and they show up as Untracked in "vac_agenthealth" view table. 

Environment

ITMS 8.x

Cause

This can happen if the AC_AgentHealthSettings table is empty. You can check for this condition by running the following query. 

select * from AC_AgentHealthSettings

If this returns no rows, then your agent health status will not work correctly. 

Resolution

You can resolve this condition by running the following SQL: 

insert into AC_AgentHealthSettings
values('88AA67FA-A787-4F82-993A-E103E9530292',1,'DAY,1',1,'DAY,1',1,'DAY,1',1,'DAY,10',1,'DAY,30',1)

This will populate the default values in that table and allow your agents health data to work correctly.

Note:
As Always, make sure you have a current backup of your database before making any changes directly.