Symantec Management Agent Service fails to start - Failed to initialize agent storage: File not found
search cancel

Symantec Management Agent Service fails to start - Failed to initialize agent storage: File not found

book

Article ID: 163228

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

The Symantec Management Agent seems to install and all the files are there but the service will not start.

 

Errors found in the Agent logs that show the SMA service and AeXAgentActivate failing to start:

[1] 10/23/2013 9:21:02 AM (AeXNSAgent.exe) Agent
Failed to initialize agent storage: File not found

 

 

 

Cause

One of the following:

Scenario 1)  Agent not fully installed

Scenario 2) Permissions have been changed on the 'MachineKeys' or 'S-1-5-18' folders under 'C:\ProgramData\Microsoft\Crypto\RSA'

 

Resolution

Scenario 1) Reinstall the agent on the system having this issue

 

Scenario 2) By default Everyone should have special permissions on the 'MachineKeys' folder and System Account should have read/write on the S-1-5-18 folder.

http://msdn.microsoft.com/en-us/library/bb909654(v=vs.90).aspx