CCS for Oracle: Job Exception Occurred,[Field] not found: [ORCL.EXAMPLE.MISSINGFIELD]
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CCS for Oracle: Job Exception Occurred,[Field] not found: [ORCL.EXAMPLE.MISSINGFIELD]

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Article ID: 163246

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Updated On:

Products

Control Compliance Suite Databases Oracle Control Compliance Suite Control Compliance Suite Standards Server

Issue/Introduction

When importing Oracle assets from the network targeting UNIX assets or when collecting data from Oracle based assets - the job reports an exception:

Job Exception Occurred,[Field] not found: [ORCL.EXAMPLE.MISSINGFIELD].

The Oracle assets do not get imported and data does not get collected.

 

Example from the logs: (the actual field will vary as it will list whatever field is missing)

5/11/2016 2:22:39 PM,Job Exception Occurred,[Field] not found: [ORCL.EXAMPLE.MISSINGFIELD],,examplenode1:###.###.###.###,UNIX Machine,,

 

Environment

CCS 12.6.X

Cause

If the CCS Application server has had a newer SCU (Security Content Update) applied, and the CCS manager(s) have not been updated with the newer SCU - this error will be displayed.

 

Resolution

The CCS Application Server and all of the CCS manager(s) are required to be at the same SCU (Security Content Update) level or you will get errors.

Check the SCU version in the CCS Console by going to Admin -> LiveUpdate to verify that the SCU that has been applied to the Application Server has also been applied to all of your CCS Managers. 

To deploy the updates to your CCS Managers using LiveUpdate, click on the Common Tasks dropdown menu and select Deploy Updates.  In the 'Edit Automatic Updates Installation Job' window, click on Next, and then check only Security Content Update and also select Push and Install and click Next.  Select the CCS Sites you would like to update the managers in and select Next. Select Use Service Account and select Next.  Make sure you select Run Now and then click through the remaining options and then click Finish
NOTE: It might take a couple times running the Automatic Updates Installation job to update all of your managers    

You can also go to Settings -> Deployment View, right-click on each of your managers and select Health and Status Details, highlight LiveUpdate on the left column, and then branch out Security Content Updates and verify that the CCS SCU is at the same version as the Application Server.  If not, update your managers to the same SCU version and run the job again.