PGP Server cannot decrypt an attachment attached to a Rich Text Format message (Symantec Encryption Management Server)
search cancel

PGP Server cannot decrypt an attachment attached to a Rich Text Format message (Symantec Encryption Management Server)

book

Article ID: 163281

calendar_today

Updated On:

Products

Encryption Management Server Gateway Email Encryption

Issue/Introduction

If the PGP Server (Symantec Encryption Management) receives a Rich Text Format message that contains a PGP-encrypted attachment, the attachment is not decrypted and the message is delivered without any changes.

If the recipient does not use PGP Desktop (Symantec Encryption Desktop), the message will be delivered with an encrypted attachment.

If the recipient *does* use PGP Desktop, the attachment *will* be decrypted by PGP Desktop.

Rich Text Format messages are used only by Microsoft Outlook.  Using HTML format will be a more widely-accepted format--encourage those you correspond with to use this encoding for best compatibility. 

Cause

At the SMTP data stream level, a Rich Text Format message consists of a file called winmail.dat. Any attachments, whether encrypted or not, are embedded in this winmail.dat file.

The PGP Server does not recognize that any part of the message is encrypted so the rule to decrypt the message does not trigger.

Resolution

There are several ways of working around this issue:

  1. Ask the sender to ensure the message is sent in HTML or Plain Text format.
  2. Ask the sender's organization to configure their Microsoft Exchange server to automatically convert Rich Text Format messages to HTML format before they are sent over the Internet to external recipients.
    This is a widely used configuration option.

  3. Provide the recipient with PGP Desktop for Email.

 

One workaround is to forward the message to an external email account that does not support Rich Text Format (such as a Gmail account) and then forward it back.

Additional Information

155681 - How to use Email Encryption with PGP Desktop and Outlook (Symantec Encryption Desktop)

163281 - PGP Server cannot decrypt an attachment attached to a Rich Text Format message (Symantec Encryption Management Server)

155940 - Unable to Decrypt with PGP Desktop - Email messages and attachments are converted to winmail.dat files