DCS ErrorCode: UMC_2311 ErrorMessage: Approval for registration of product 'DCS Server' failed because of failure in download of product package.
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DCS ErrorCode: UMC_2311 ErrorMessage: Approval for registration of product 'DCS Server' failed because of failure in download of product package.

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Article ID: 163373

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Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

You just ran the registerProduct.bat batch file to register the DCS manager to the UMC and are presented with the below error. In addition, when looking at the UMC console, Settings, Product Setup, you cannot approve the DCS manager registration request. 

registerProduct.log:

ERROR: Invocation of umcRegistrationClientAPI.registerProduct failed on error:  {"errorResponse":{"errorCode":"UMC_2311","errorMsg":"Approval for registration of product 'DCS Server' failed because of failure in download of product package.","errorRemedy":"Download of product package can fail due to network connectivity issues (host or port name is not reachable, unable to resolve hostname, web server is down etc.). Ensure that the connectivity is available and try again or contact Administrator if the problem persists."}}, cause: null
ERROR: UMCRegistration.registerProduct() failed due to error:  {"errorResponse":{"errorCode":"UMC_2311","errorMsg":"Approval for registration of product 'DCS Server' failed because of failure in download of product package.","errorRemedy":"Download of product package can fail due to network connectivity issues (host or port name is not reachable, unable to resolve hostname, web server is down etc.). Ensure that the connectivity is available and try again or contact Administrator if the problem persists."}}

umclog.log:

2016-06-22 13:58:38 INFO  ProductPackageManager:238 - Registration Acknowledgment: Start sending acknowledgment to product 'DCS Server'.
2016-06-22 13:58:38 INFO  ProductPackageManager:250 - Registration Acknowledgment: Sending acknowledgment for product 'DCS Server' on 'https://{ip of DCS manager}:4443/sis-ui/api/rest/v1.0/package/downloadack'.
2016-06-22 13:58:38 INFO  ProductPackageManager:266 - Registration Acknowledgment: Sending acknowledgment data '{"registrationStatus":1,"productId":"3","umcHostname":"{ip of UMC","umcPort":8443,"productVersion":"6.6","umcVersion":"6.6"}'.
2016-06-22 13:59:41 ERROR ProductRegistrationDAO:1299 - Failed to send acknowledgment to point product '{DCS Server}' with error.
com.symantec.dcsc.umc.webportal.exceptions.ProductRegistrationException: Failure in sending the product 'DCS Server' registration status acknowledgement.
 

Cause

As suggested within the error, the host (DCS manager in this case) or port name is not reachable, unable to resolve hostname, web server is down etc.

Resolution

Make sure the required ports are open and if a hostname is used, the hostname can be resolved to an IP address. Review the DCSSA Planning and Deployment Guide, "Figure 1-2 DCS: Server ports" to open the appropiate ports. Don't forget about the windows client firewall potentially running on the DCS manager - open the appropriate ports there too.

Link to full DCS 6.6 documentation set including the Planning and Deployment guide.