Error 'Failed to configure SEPM Controller connection'
search cancel

Error 'Failed to configure SEPM Controller connection'

book

Article ID: 163745

calendar_today

Updated On:

Products

Endpoint Protection Endpoint Detection and Response Advanced Threat Protection Platform

Issue/Introduction

After configuring your Advanced Threat Protection (ATP) Platform, while adding a Symantec Endpoint Protection Manager (SEPM) Controller connection, ATP displays an error that the operation failed.

Cause

The Symantec Endpoint Protection Manager API Service is stopped,

Or

The hostname for the ATP manager is not 'localhost.localdomain'. This can happen by manually changing it using the hostname command or if there is an A record in the local DNS for the ATP, the software will assign it to itself.

Resolution

Start the Symantec Endpoint Protection Manager API Service if stopped,

Or

Revert the hostname to its default value if required:

  1. To revert the hostname to localhost.localdomain, within ATP CLI, type:
    hostname localhost.localdomain
     
  2. Upgrade to ATP 3.0
  3. Within ATP CLI, to set the hostname to the desired hostname using the hostname command, type:
    hostname targetname

    ...where targetname is the desired new hostname 

 

This issue is also resolved with a SEPM upgrade to 14RU1 (whilst leaving ATP on v2.3). If you are not able to upgrade immediately, please workaround this issue by reverting the hostname to localhost.localdomain, then attempting to configure the SEPM Controller connection.