Symantec Data Center Security:Server Advanced java console: Login Failed. SDCSS could not log you on. Make sure your user name is correct, then type your password again.
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Symantec Data Center Security:Server Advanced java console: Login Failed. SDCSS could not log you on. Make sure your user name is correct, then type your password again.

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Article ID: 163990

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Updated On:

Products

Critical System Protection Data Center Security Server Data Center Security Server Advanced

Issue/Introduction

You are trying to log on to the Symantec Data Center Security:Server Advanced java console and get the error message: "Login Failed. SDCSS could not log you on. Make sure your user name is correct, then type your password again". You are pretty sure you got the right password and even resetting the password does not seem to help.

 

C:\Program Files (x86)\Symantec\Data Center Security Server\Server\manager.err file:

Nov 29, 2016 2:32:21 PM org.apache.tomcat.util.digester.Digester fatalError
SEVERE: Parse Fatal Error at line 105 column 9: The string "--" is not permitted within comments.
org.xml.sax.SAXParseException; systemId: jndi:/localhost/sis-ui/WEB-INF/web.xml; lineNumber: 105; columnNumber: 9; The string "--" is not permitted within comments.
  

Nov 29, 2016 2:32:21 PM org.apache.catalina.startup.ContextConfig parseWebXml
SEVERE: Occurred at line 105 column 9
Nov 29, 2016 2:32:21 PM org.apache.catalina.startup.ContextConfig configureStart
SEVERE: Marking this application unavailable due to previous error(s)
Nov 29, 2016 2:32:21 PM org.apache.catalina.startup.TldConfig execute
INFO: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
Nov 29, 2016 2:32:21 PM org.apache.catalina.core.StandardContext startInternal
SEVERE: One or more components marked the context as not correctly configured
Nov 29, 2016 2:32:21 PM org.apache.catalina.core.StandardContext startInternal
SEVERE: Context [/sis-ui] startup failed due to previous errors

To add to this, when connecting to Unified Management Console (UMC) and the Assets tab, you could be presented with the error:

System error: Unable to connect to DCS: server. Ensure you have accepted the DCS: Server certificate in the web browser. If the problem persistes, contact service administrator.

Last - and this is also indicative of an issue with the "Symantec Data Center Security Server Manager" service is the lack of the creation/updating of log files like sis-server.0.log etc in C:\Program Files (x86)\Symantec\Data Center Security Server\Server\tomcat\logs. To verify this, stop the "Symantec Data Center Security Server Manager" service, delete (or move) the logs in C:\Program Files (x86)\Symantec\Data Center Security Server\Server\tomcat\logs and start the "Symantec Data Center Security Server Manager" service again. If you don't get sis-agent.0.log, sis-server.0.log and etc sis-restapi.0.log files etc. then look at C:\Program Files (x86)\Symantec\Data Center Security Server\Server\manager.err file and review & fix any errors there.

 

Environment

Symantec Data Center Security:Server Advanced 6.x

 

Cause

In this case, the error in C:\Program Files (x86)\Symantec\Data Center Security Server\Server\manager.err file is pointing to a corrupt web.xml file.

SEVERE: Parse error in application web.xml file at jndi:/localhost/sis-ui/WEB-INF/web.xml
org.xml.sax.SAXParseException; systemId: jndi:/localhost/sis-ui/WEB-INF/web.xml; lineNumber: 105; columnNumber: 9; The string "--" is not permitted within comments.

It remains unknown what caused the web.xml file to render corrupted.

 

Resolution

  1. Stop the "Symantec Data Center Security Server Manager" service
  2. Delete (don't just rename) the C:\Program Files (x86)\Symantec\Data Center Security Server\Server\tomcat\symapps\console\sis-ui directory
  3. Start the "Symantec Data Center Security Server Manager" service (the sis-ui directory and contents will be recreated from the C:\Program Files (x86)\Symantec\Data Center Security Server\Server\tomcat\symapps\console\sis-ui.war file)

At this point the "Symantec Data Center Security Server Manager" service should start again, fresh logs be generated in C:\Program Files (x86)\Symantec\Data Center Security Server\Server\tomcat\logs (see sis-server.0.log for evidence the manager started) and most importantly, you should be able to log on to the java console and the UMC console can connect again too.