Error Failed push install of the Symantec Management Agent to: reference. Machine name must not be null or empty.
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Error Failed push install of the Symantec Management Agent to: reference. Machine name must not be null or empty.

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Article ID: 164794

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Updated On:

Products

IT Management Suite

Issue/Introduction

When trying to push the Symantec Management Agent (SMA) to certain machines, the error "Failed to push the Symantec Management Agent to ..." and "Machine name must not be null or empty" is generated.

 

We noticed that the SMA Install page uses a target that is formed by these targets:

Windows Computers with no SMA Installed
All Unmanaged Workstations
SMP Client Exclusions
Unmanaged PAT Workstations

Error:
Failed to push the Symantec Management Agent to: '<Agent Guid Here>.<no domain>'

Machine name must not be null or empty.
Parameter name: machineName
 <some lines removed for clairity>
-----------------------------------------------------------------------------------------------------
Process: AeXSvc (1476), Thread ID: 245, Module: Altiris.NS.dll
Priority: 1, Source: Altiris.NS.Utilities.ClientPushMgr.DiscoveryAndPush

Warning 1:

Failed to discover computer details: [High] '<agent GUID here>.<no domain>'

Failed to discover domain details for: , error=1702
<removed entries>
COM Exception errcode: 0x6A6
-----------------------------------------------------------------------------------------------------
Date: 3/6/2017 9:30:08 AM, Tick Count: 419711844 (4.20:35:11.8440000), Size: 2.53 KB
Process: AeXSvc (1476), Thread ID: 245, Module: Altiris.NS.dll
Priority: 2, Source: Altiris.NS.AgentManagement.ClientPushInstall.AgentPushDataWindowsDiscovery+DiscoveryData.Discover

Warning 2:
Failed to discover domain details for: , error=1702
-----------------------------------------------------------------------------------------------------
Date: 3/6/2017 9:30:08 AM, Tick Count: 419711844 (4.20:35:11.8440000), Size: 267 B
Process: AeXSvc (1476), Thread ID: 245, Module: Altiris.NS.dll
Priority: 2, Source: DiscoverMachines

Example of the error in Log Viewer

Environment

SMP 8.0 HF6 and later

Cause

Inv_AeX_AC_Identification table does not contain all the necessary details for the agent to be pushed, which caused that AgentPushData to have incomplete references. Inv_AeX_AC_Identification can be populated from different sources, like AD Import, Network Discovery or some sort of Data Connector import.

Resolution

Check the AgentPushData table and verify that this machine in fact is missing the machine name:
--Query 1:
SELECT * from AgentPushData where GUID = '<Agent GUID from error message>'

--Results from query 1 will be similar to the following (possibly with different OS version data):
<Agent GUID from error message> NULL NULL NULL Windows 7 Professional 6.1.7601 Win32

Make sure that whatever mechanism you are using to import this unmanaged machines has the proper details. In this particular case we need the Machine Name and Domain.