Unable to connect to the database or SQL user does not have permission when installing Endpoint Protection Manager 14
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Unable to connect to the database or SQL user does not have permission when installing Endpoint Protection Manager 14

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Article ID: 164797

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Updated On:

Products

Endpoint Protection

Issue/Introduction

You encounter errors when you run the Management Server Configuration Wizard (MSCW) and attempt to connect to a SQL Server database after you install or upgrade Symantec Endpoint Protection Manager (SEPM) to version 14.

Pop-ups errors from MSCW:

Error 11501: Unable to connect to the database.

The user <sem5> does not have SQL Server ALTER ANY LOGON permission.

Errors in Symantec Endpoint Protection Manager installation directory (e.g. Program_Files\Symantec\Symantec Endpoint Protection Manager\tomcat\logs\upgrade0.log):

The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption.

Server chose SSLv3, but that protocol version is not enabled or not supported by the client.

Environment

Microsoft Windows Server and SQL Server database

Symantec Endpoint Protection Manager 14

Cause

These errors occur if Windows SSL/TLS connections are restricted to allow only TLS 1.2 and the SQL Server version is not compatible with TLS 1.2.

Resolution

Install, upgrade, or otherwise patch SQL Server to a version that is compatible with TLS 1.2. See the following for more information:

TLS 1.2 support for Microsoft SQL Server

When complete, reboot the server that runs SQL Server if necessary, and re-run the Symantec Endpoint Protection Manager upgrade as Administrator (Program_Files\Symantec\Symantec Endpoint Protection Manager\bin\upgrade.bat).

References