Premium Antispam does not scan for spam
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Premium Antispam does not scan for spam

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Article ID: 164987

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

Premium Antispam in Mail Security for Microsoft Exchange (SMSMSE) is not scanning for spam. The activity counter on the home page of the SMSMSE console stays at 0 for spam scans, despite Premium AntiSpam being licensed and enabled.

In the System event log, an event ID 10016 from source Distributed COM with the following details is logged:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID 
{05283737-9617-4770-9411-BC4E100F62F6}
 and APPID 
{9050D46B-FBDB-4D32-8A98-EA601E03FBAE}
 to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Cause

The Microsoft Exchange Transport service, which runs under the Network Service account, does not have DCOM Local Activation permission to the SAVFMSESpamStatsManager class. 

Resolution

Add Local Activation permission to the Network Service account on SAVFMSESpamStatsManager Class in DCOM configuration.

To add Local activation permission

  1. ​Open the DCOM configuration MMC (Start -> Run, type dcomcnfg and press Enter)
  2. In the Component Services window, in the left pane, expand Component Services -> Computers -> My Computer -> DCOM Config
  3. Right click the object SAVFMSESpamStatsManager and select Properties.
  4. Select the Security tab and under Launch and Activation permissions select Customize, then click Edit...
  5. In the Launch and Activation Permission dialog Click Add...
  6. In the "Enter the obect names to select" box, type Network Service and click OK.
  7. Check Allow for "Local Launch" and "Local Activation" and click OK.
  8. Repeat steps 5 - 7 for "SMSMSE Admins" & "SMSMSE Viewers"
  9. In the "SAVFMSESpamStatsManager Properties" dialog, click OK.
  10. Close the Component services window.
  11. Restart the Microsoft Exchange Transport and Symantec Mail Security Utility services.