Unable to register itself as a Task Server or unable to get package snapshots
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Unable to register itself as a Task Server or unable to get package snapshots

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Article ID: 165005

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Updated On:

Products

IT Management Suite

Issue/Introduction

The customer recently added one of his machines as a Site Server. He enabled the Package and Task Services and those were installed on the machine. However, when he looked at the machine, he noticed that the machine couldn't register itself as a Task Server or failed to get package snapshots. He saw errors like:

Error 1:
Package Server could not access its own Web Site using HTTPS, although it is configured to serve it. The HTTPS requests from clients cannot be served.

Error 2:
Could not register using "https://<TaskServer01>.<Domain>:443/Altiris/ClientTaskServer/Register.aspx"

Error 3:
Error code: HTTP status 500: An unexpected condition prevented the server from fulfilling the request (0x8FA101F4)

Error 4:
Download Snapshot failed: HTTP error occured (-2147209951)

Entry 1:

Operation 'Direct: Head' failed.
Protocol: HTTPS
Original Host: <TaskServer01>.<Domain>:443
Real Host: <NSserver01>:443
Path: /Altiris/ClientTaskServer/Register.aspx
Id: 232.7188
Error type: HTTP error
Error code: HTTP status 500: An unexpected condition prevented the server from fulfilling the request (0x8FA101F4)
Error note: 500 Internal Server Error
Server HTTPS connection info:
   Server certificate:
      Serial number: 7a 6d 1f ca ad 5b f9 61 f7 da 2b 57 2f c3 2f 42 1c 74 9c 67
      Thumbprint: ad 32 9b c4 98 a7 59 ff fb 43 de 04 2c cc b3 8c 57 ea 08 fb
   Cryptographic protocol: TLS 1.0
   Cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA_P256
   Cipher algorithm: AES
   Cipher key length: 256
   Hash algorithm: SHA1
   Hash length: 160
   Key exchange algorithm: ECDH_P256
   Key length: 256
-----------------------------------------------------------------------------------------------------
Date: 4/5/2017 12:58:14 AM, Tick Count: 1824800687 (21.02:53:20.6870000), Size: 1.07 KB
Process: AeXNSAgent.exe (7188), Thread ID: 5892, Module: AeXNetComms.dll
Priority: 1, Source: NetworkOperation
 

Entry 2:

Could not register using "https://<TaskServer01>.<Domain>:443/Altiris/ClientTaskServer/Register.aspx"
-----------------------------------------------------------------------------------------------------
Date: 4/5/2017 12:58:14 AM, Tick Count: 1824800687 (21.02:53:20.6870000), Size: 355 B
Process: AeXNSAgent.exe (7188), Thread ID: 5892, Module: client task agent.dll
Priority: 2, Source: Client Task Agent
 

Entry 3:

Operation 'Direct: Get' failed.
Protocol: HTTPS
Host: <NSserver01>.<Domain>:4726
Path: /Altiris/PS/getpackagesnapshot.asp
Id: 181.3512
Error type: HTTP error
Error code: HTTP status 500: An unexpected condition prevented the server from fulfilling the request (0x8FA101F4)
Error note: Empty response content received
Server HTTPS connection info:
   Server certificate:
      Serial number: 58 c5 7e 69 3b d9 f6 c6 32 25 39 b0 24 9c af 9e d2 ec 62 68
      Thumbprint: 02 ed 60 da c1 e7 d3 30 a6 38 fa 24 1b 05 eb f2 db d7 c5 72
   Cryptographic protocol: TLS 1.0
   Cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA_P256
   Cipher algorithm: AES
   Cipher key length: 256
   Hash algorithm: SHA1
   Hash length: 160
   Key exchange algorithm: ECDH_P256
   Key length: 256
-----------------------------------------------------------------------------------------------------
Date: 4/5/2017 1:19:58 AM, Tick Count: 1831471921 (21.04:44:31.9210000), Size: 1.03 KB
Process: AeXNSAgent.exe (3512), Thread ID: 6468, Module: AeXNetComms.dll
Priority: 1, Source: NetworkOperation
 

Entry 4:

Operation 'Direct: Get' failed.
Protocol: HTTP
Host: <TaskServer02>.<Domain>:80
Path: /Altiris/PS/getpackagesnapshot.asp
Id: 180.3512
Error type: HTTP error
Error code: HTTP status 500: An unexpected condition prevented the server from fulfilling the request (0x8FA101F4)
Error note: Empty response content received
-----------------------------------------------------------------------------------------------------
Date: 4/5/2017 1:19:56 AM, Tick Count: 1831469953 (21.04:44:29.9530000), Size: 576 B
Process: AeXNSAgent.exe (3512), Thread ID: 6468, Module: AeXNetComms.dll
Priority: 1, Source: NetworkOperation
 

Entry 5:

Download Snapshot failed: HTTP error occured (-2147209951)
-----------------------------------------------------------------------------------------------------
Date: 4/5/2017 1:14:57 AM, Tick Count: 1831171421 (21.04:39:31.4210000), Size: 304 B
Process: AeXNSAgent.exe (3512), Thread ID: 6468, Module: AeXPackageDelivery.dll
Priority: 1, Source: PackageDownload
 

Entry 6:

Package Server could not access own Web Site using HTTPS, although it is configured to serve it. The HTTPS requests from clients cannot be served. See logs for detailed failure reason. (health state: 0x00001331).
-----------------------------------------------------------------------------------------------------
Date: 4/5/2017 1:14:03 AM, Tick Count: 1831116906 (21.04:38:36.9060000), Size: 464 B
Process: AeXNSAgent.exe (3512), Thread ID: 7104, Module: AeXNSCPackageServer.dll
Priority: 1, Source: Package Server Agent

 

As well similar messages can be noticed in the IIS logs:

SVC1 <TaskServer02> <IP Address> HEAD /Altiris/ClientTaskServer/Register.aspx lastResort=true&resourceGuid=94a3fd5f-7929-4a8d-8e61-1fd1ef331675&crc=00080001000011B0 4726 - 12.220.44.127 HTTP/1.1 - - - <TaskServer02>.<Domain> 401 5 293 235 109

2017-04-21 19:40:00 W3SVC1 <TaskServer02> <IP Address> HEAD /Altiris/ClientTaskServer/Register.aspx - 443 - <IP Address>.83 HTTP/1.1 - - - <TaskServer02>.<Domain> 401 5 293 148 31

Environment

ITMS 8.1 and later

Cause

Cause 1:
Missing the proper permissions for "Authenticated Users" group under <installdrive>:\Program Files\Altiris\Altiris Agent

Cause 2:
An Update (possibly WSUS) or installation other inserted a line into ApplicationHost.config when it registered its WSUS x64 DLL-- which turned on Dynamic Compression (as opposed to Static Compression which is probably already enabled), or an update was run that did not complete or clean up after its self.

In this case, the following section was added to "C:\Windows\System32\inetsrv\ApplicationHost.config".   The path to the compression DLL existed, but file did not:

<scheme name="xpress" doStaticCompression="false" doDynamicCompression="true" dll="C:\Program Files\Update Services\WebServices\suscomp.dll" staticCompressionLevel="10" dynamicCompressionLevel="0" />

Cause 3:
While trying "https://<TaskServer01>.<Domain>.com:443/Altiris/ClientTaskServer/Register.aspx", the following error occurred:

This error indicated an issue with IIS and the "\package server agent\web.config", which is an unusual call when trying to access the "ClientTaskServer/Register.aspx". 

Resolution

Cause 1:
Grant the following permissions to "Authenticated Users" group under the <installdrive>:\Program Files\Altiris folder:

  • Read and Execute
  • List Folder Contents
  • Read


Cause 2:
Since static compression is preferred for Task and Package Server agent activities, do the following:

  1. Open "C:\Windows\System32\inetsrv\config\ApplicationHost.config"
  2. Copy the ApplicationHost.config file to a backup folder in case there are worse problems after following the next steps (not likely).
  3. Look for something similar to the following:
    <scheme name="xpress" doStaticCompression="false" doDynamicCompression="true" dll="C:\Program Files\Update Services\WebServices\suscomp.dll" staticCompressionLevel="10" dynamicCompressionLevel="0" />
  4. Also look for a section right below it outlying dynamic compress content, such as follows:
                <dynamicTypes>
                    <add mimeType="text/*" enabled="true" />
                    <add mimeType="message/*" enabled="true" />
                    <add mimeType="application/x-javascript" enabled="true" />
                    <add mimeType="application/javascript" enabled="true" />
                    <add mimeType="*/*" enabled="false" />
                </dynamicTypes>
  5. If one or both of the previous declarations are found in the config file, delete them and save the file.
  6. Reset IIS (from the command prompt running as Administrator):  IISRESET.
  7. Restart Symantec Management Agent service as well 

 

Cause 3:

1. Go to "...\Program Files\Altiris\Altiris Agent\Package Server Agent" folder and verify that the "Web.config" looks like this:

2. If it is different, grab the same web.config from another Package Server and copy and replace it.

3. Restart Agent service. 

Additional Information

173124 "Package download fails with error: HTTP status 500: An unexpected condition prevented the server from fulfilling the request (0x8FA101F4)"