Premium AntiSpam does not scan for spam
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Premium AntiSpam does not scan for spam

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Article ID: 165014

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

Premium AntiSpam for Symantec Mail Security for Microsoft Exchange (SMSMSE) does not scan for spam. The activity counter on the home page of the SMSMSE console stays at 0 for spam scans, despite Premium AntiSpam being licensed and enabled.

In the application event log, an event id 378 is logged with the following details:

PremiumAntiSpamSettings: Error reading SPA settings from dataset.

Source : d::a Thread:94
a at offset 322 in file:line:column <filename unknown>:0:0

Cause

The Microsoft Exchange Transport service which runs under the Network service account does not have access to the settings file for Premium Antispam.

Resolution

Enable access to the SMSMSE directory for the Network service account.

To enable access to the SMSMSE directory for the Network service account:

  1. Open Windows Explorer and navigate to:
    7.5.6 and earlier: C:\Program Files (x86)\Symantec\SMSMSE\<version>. 
    7.9.0 and later: C:\Program Files\Symantec\SMSMSE\<version>.
  2. Right click the Server directory and select Properties.
  3. Select the Security tab.
  4. Next to the "To change permissions, click Edit." dialog, click Edit...
  5. Click Add...
  6. In the "Enter the object names to select:" box, type NETWORK SERVICE and click OK.
  7. Select the "Allow" box next to "Full control" click Apply and click OK.
  8. Restart the Microsoft Exchange Transport service.