Troubleshooting High CPU usage on Edge SWG (ProxySG) or Advanced Secure Gateway
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Troubleshooting High CPU usage on Edge SWG (ProxySG) or Advanced Secure Gateway

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Article ID: 167114

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Updated On:

Products

Advanced Secure Gateway Software - ASG ProxySG Software - SGOS ISG Proxy

Issue/Introduction

Troubleshoot high CPU utilization issues on the Edge SWG (ProxySG) or Advanced Secure Gateway (ASG).

Cause

Known issues that can cause high CPU usage:

  • Traffic 
  •  Lack of available resources to process data 
  •  Complex configuration or policy

Resolution

This article provides the steps to troubleshoot utilization issues, with links to supporting procedures and common causes of high CPU utilization on the Edge SWG (ProxySG) or ASG.

Troubleshooting considerations

To help identify the cause of the high CPU utilization, consider the following questions while progressing through the troubleshooting steps:

  • Is the proxy continuously at high CPU, or does it peak at certain times?
  • Does the CPU utilization come down after production hours?
  • Does the CPU utilization peak periodically then go back to "normal"? If so, can you graph out the peaks, and identify a trend?
  • Has anything recently changed in the environment that may have triggered the issue such as:
    • An increase in network traffic
    • New applications introduced
    • Configuration changes on the Edge SWG (ProxySG) or ASG or associated network devices
    • Etc.

Enable CPU Monitor

The first step to troubleshoot the issue is to enable the CPU monitor on the Edge SWG (ProxySG) or ASG and to activate snapshots every five minutes. This step helps determine which service or services generate the high utilization. The CPU monitor can be accessed at:

https://x.x.x.x:8082/Diagnostics/CPU_Monitor/statistics 
(where x.x.x.x is the IP address or hostname of the SG appliance) 

For more information on how to set up the CPU monitor, see: How to enable the CPU Monitor on the Edge SWG (ProxySG)

NOTE: Once you have finished taking snapshots, be sure to turn the CPU monitor off as it places additional CPU load on the system.

Common causes for high CPU usage

After CPU Monitor identifies the source of the high CPU utilization, use the following articles to review the most common causes and resolutions for high CPU utilization for that service:

Other environmental factors and configurations that can cause high CPU usage

If the above articles did not help resolve the high CPU utilization issue, these articles also document defects or configurations that can cause this issue:

Capturing logs for Support

If you are still unable to resolve the high CPU utilization issue, you will need to open a ticket with Broadcom Support.

In addition to the details from the CPU Monitor, you may also be asked to provide the following:

SysInfo

  • The SysInfo information should be captured after the CPU utilization has returned to normal, or after 20 minutes of high utilization for a persistent utilization spike.
  • This information can be uploaded through the management console Maintenance tab or captured from the URL https://<proxy_ip>:8082/Sysinfo

Event Log

  • The Event Log should be captured after the CPU utilization has returned to normal or after 20 minutes of high utilization for a persistent utilization spike.
  • This information can be uploaded through the management console Maintenance tab or captured from the URL https://<proxy_ip>:8082/Eventlog/Statistics
  •  

TCP Users

While the CPU utilization is high, copy the output from the URL https://<proxy_ip>:8082/TCP/Users

SysInfo_stats snapshots

Configure snapshots on the Edge SWG to occur every five minutes (default is 60), and run for at least 20 minutes during the CPU spike.

Full core (optional)

Depending on the nature and symptoms of the high utilization issue, you may be asked to provide a full core dump of the Edge SWG (ProxySG).