'license update' command does not work on PacketShaper S-Series; what can be done?
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'license update' command does not work on PacketShaper S-Series; what can be done?

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Article ID: 168666

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Updated On:

Products

PacketShaper S-Series

Issue/Introduction

Although the output from the license update CLI command says that the license has been updated, after rebooting the PacketShaper the unit still says the license is missing.

Cause

This is an intermittent issue, it may work at times but we have noticed this command may not always be successful.

Resolution

Here are the steps to manually download and load the license:

  1. Get the license file from Broadcom Download Portal at https://support.broadcom.com/group/ecx/products Enter the Serial Number of the unit and search. Go to the leaf object and click on Licenses to download the 'License key'.
  2. Save the file to your local workstation. 
  3. Open a browser, log in to the PacketShaper, and click on Advanced UI
  4. Click on the Info tab and then File Browser.   
Note: The File Browser defaults to the Public folder.  Do not change the folder and upload to a different directory. (Only advanced users should upload to a different directory.)
  1. Click the Upload button and choose the license file. 
  2. Click Upload and wait for success message. 
  3. Open a CLI session to the PacketShaper.  
  4. Type: license load file://localhost/9.256/license_.bcl
Updating license from: file://localhost/license_.bcl
License is updated.
  1. Enter reset to activate the new license.
  2. After resetting the PacketShaper, type ver ver from the command line and confirm that the license has been updated.