"Java not enabled" message displayed in browser when launching the VPM editor in Management Center
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"Java not enabled" message displayed in browser when launching the VPM editor in Management Center

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Article ID: 168822

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Updated On:

Products

Management Center

Issue/Introduction

The Launch VPM Editor button is greyed out and the system displays a message stating that Java is not enabled.

Cause

This can be caused by the following:
  • Java not being installed or not at the latest required version.
  • Java not being available to the browser as a plugin.
  • Required TLS protocols not available to the browser\Java.
  • Issue with Management Center version preventing the VPM from launching.

Resolution

First, verify that Java is enabled in the browser and in Java itself.  You can also find this information from the Java website.
 
Internet Explorer
  1. Click Tools and then Internet Options
  2. Select the Security tab, and select the Custom Level button
  3. Scroll down to Scripting of Java applets
  4. Make sure the Enable radio button is checked
  5. Click OK to save your preference
Chrome

Chrome browser versions 42 and above. Starting with Chrome version 42 (released April 2015), Chrome has disabled the standard way in which browsers support Java plugins. 


Firefox
  1. Open the Firefox browser or restart it, if it is already running
  2. From the Firefox menu, select Tools, then click the Add-ons option
  3. In the Add-ons Manager window, select Plugins
  4. Click Java (TM) Platform plugin (Windows) or Java Applet Plug-in (Mac OS X) to select it
  5. Check that the option selected is Ask to Activate or Always Activate or on older Firefox versions, click on the Enable button (if the button says Disable, Java is already enabled)
Enable Java in the browser through the Java Control Panel
  1. In the Java Control Panel, click the Security tab.
  2. Select the option Enable Java content in the browser.
  3. Click Apply and then OK to confirm the changes.
  4. Restart the browser to enable the changes.

Navigate to the following URL to verify that Java is working properly:

http://www.java.com/en/download/installed.jsp

If this is unsuccessful in Internet Explorer, examine the browser settings to determine if Java is having issues.  For example, check Manage Add-ons in Internet Explorer and see if Java is disabled under Status.

To check Java Add-on status
  1. Open IE and click Tools and then Internet Options
  2. Click Programs Tab and click Manage Add-ons
Here you can see if the Java plugin is disabled or in another state.  If Java is not enabled, address this by reinstalling Java or continuing to troubleshoot.

Ensure TLS1.1 and TLS1.2 are available

Check that these TLS versions are enabled in Internet Explorer, under Tools -> Internet Options -> Advanced. Check TLS 1.1 and TLS 1.2.
Within the Java Control Panel, Select Advanced. Enable the same protocols.

Ensure Management Center is running at least version 1.5.1.1

Finally, if you are using Internet Explorer 11 with Java 8, please ensure that Management Center is running version 1.5.1.1 or later as a known issue with loading the VPM on these versions of IE and Java has been fixed.