Error "An IO Exception has occurred while accessing file" during download MSI file process within SIM
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Error "An IO Exception has occurred while accessing file" during download MSI file process within SIM

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Article ID: 169778

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Updated On:

Products

IT Management Suite Client Management Suite Server Management Suite

Issue/Introduction

While trying to install ITMS 8.x in a new server, the following error appeared in the SIM install logs during the MSI download file process:

An IO Exception has occurred while accessing file.
Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

When trying to access the file using the download link directly from the IE browser, for example:
https://www.solutionsam.com/solutions/8_6/altiris_pluggableprotocols_agent_8_6_x64.msi

Internet Explorer failed to download the file and displayed this message:

"This program couldn't be downloaded"

Entry 1:
DownloadFile - Downloading file from 'https://www.solutionsam.com/solutions/8_6/altiris_pluggableprotocols_agent_8_6_x64.msi' to 'file:///D:/Program Files/Altiris/Symantec Installation Manager/Installs/Altiris/altiris_pluggableprotocols_agent_8_6_x64.msi'
-----------------------------------------------------------------------------------------------------
Date: 3/22/2021 2:33:13 PM, Tick Count: 11866296 (03:17:46.2960000), Size: 545 B
Process: SymantecInstallationManager (7160), Thread ID: 19, Module: SymantecInstallationManager.exe
Priority: 4, Source: Symantec.Installation.FileDownloader.DownloadFile

 

Entry 2:

Exception while accessing[https://www.solutionsam.com/solutions/8_6/altiris_diagnostics_8_6_x64.msi]. A message was received that exceeded the specified limit when sending a request or receiving a response from the server.
The remote name could not be resolved: 'www.solutionsam.com'
   [System.Net.WebException @ System]
   at System.Net.HttpWebRequest.GetResponse()
   at Symantec.Installation.FileDownloader.OpenHttpStream(Uri fileUri, Func`2 func, Action`1 initRequest)

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.FileDownloader.ProcessWebException(String url, WebException webException)
   at Symantec.Installation.FileDownloader.OpenHttpStream(Uri fileUri, Func`2 func, Action`1 initRequest)
   at Symantec.Installation.FileDownloader.<>c__DisplayClass58_0.<DownloadFile>b__0()
   at Symantec.Installation.FileDownloader.FileOperation(Func`1 action)
   at Symantec.Installation.FileDownloader.DownloadFile(Uri sourceUri, Uri destinationUri, Int64 fileSize)
   at Symantec.Installation.FileDownloader.DownloadFile(Uri source, Func`2 downloader, Int32 maxRetryCount)
   at Symantec.Installation.FileDownloader.<DownloadFiles>b__54_0(DownloadFileInfo downloadFileInfo, ParallelLoopState state)
   at System.Threading.Tasks.Parallel.<>c__DisplayClass17_0`1.<ForWorker>b__1()
   at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask)
   at System.Threading.Tasks.Task.<>c__DisplayClass176_0.<ExecuteSelfReplicating>b__0(Object )
   at System.Threading.Tasks.Task.Execute()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot)
   at System.Threading.Tasks.Task.ExecuteEntry(Boolean bPreventDoubleExecution)
   at System.Threading.ThreadPoolWorkQueue.Dispatch()


-----------------------------------------------------------------------------------------------------
Date: 3/22/2021 2:33:13 PM, Tick Count: 11866296 (03:17:46.2960000), Size: 2.54 KB
Process: SymantecInstallationManager (7160), Thread ID: 25, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.FileDownloader.ProcessWebException

 

Entry 3:
Failed to validate file 'D:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris\altiris_diagnostics_8_6_x64.msi' File hash does not match: reference hash: 873f397ff7d1fe252aa3d2ea9f1106a79928cb8c1ae40340891e1517393b8a17/computed hash: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
-----------------------------------------------------------------------------------------------------
Date: 3/22/2021 2:33:16 PM, Tick Count: 11869515 (03:17:49.5150000), Size: 620 B
Process: SymantecInstallationManager (7160), Thread ID: 25, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.InstallClasses.FileValidator.ValidateFile


Entry 4:
The following files have failed to validate: 
https://www.solutionsam.com/solutions/8_6/altiris_diagnostics_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_nscommon_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_ns_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_resourcemgmt_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_webcontrols_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_reporting_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_nsreports_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_console_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_taskmanagement_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_taskservertasks_8_6_x64.msi
https://www.solutionsam.com/solutions/8_6/altiris_inventoryrulemanagement_8_6_x64.msi
...

This will affect the following product(s): 
Altiris Client Management Suite Portal Page (7.1.1005)
Altiris Deployment Solution 8.6 (8.6.1066)
Altiris Event Console 8.6 (8.6.1011)
Altiris Inventory Solution 8.6 (8.6.1052)
Altiris IT Analytics 8.6 (8.6.1010)
Altiris IT Analytics Client Server Management Pack 8.6 (8.6.1010)
Altiris Patch Management Solution 8.6 (8.6.1054)
Altiris Power Scheme Task 8.5 (8.5.3006)
Altiris Real-Time Console Infrastructure 8.6 (8.6.1009)
Altiris Real-Time System Manager 8.6 (8.6.1009)
Altiris Software Management Solution 8.6 (8.6.1095)
...
Click Retry to try again or Cancel to exit this wizard.
-----------------------------------------------------------------------------------------------------
Date: 3/22/2021 2:33:17 PM, Tick Count: 11869718 (03:17:49.7180000), Size: 1.77 KB
Process: SymantecInstallationManager (7160), Thread ID: 25, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Context.WizardProcess.DownloadManager.FileValidationComplete

Environment

New installation ITMS 8.1 or later

Symantec Installation Manager 8.1.5037 or later

Cause

Environmental. In this particular instance, the firewall was blocking some of the download traffic. Proxy servers can cause the same issue.

Resolution

The issue was resolved by configuring the firewall to allow communication to the www.solutionsam.com site and traffic to the servers where the MSIs are hosted.

Other things that could help on similar behavior: 

  1. Verify that there is not a proxy blocking the download process.
  2. Verify that there is not an antivirus locking the destination drive.

Also, check that SIM is configured to use your proxy settings:

1. Open SIM.

2. Go to "Settings"

3. Click "Change" under "Proxy Settings"

4. Select "User specified proxy settings" and add the proper information.