Error: 'Restarting system' displayed on Advanced Secure Gateway appliances
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Error: 'Restarting system' displayed on Advanced Secure Gateway appliances

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Article ID: 169825

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Updated On:

Products

Advanced Secure Gateway Software - ASG ASG-S200 ASG-S400 ASG-S500

Issue/Introduction

Advanced Secure Gateway (ASG) appliances may encounter issues after upgrading and trying to load a newly installed version of ASG. There are two scenarios that have been observed:

  1. The message "Restarting system" is displayed before the appliance restarts and boots back to another code version.
  2. The message "In MP mode; <number_of_processors> processors active" is repeatedly displayed.

SCENARIO 1:
​The following example displays the serial output when an updated version of ASG fails to load and the message "Restarting system" is displayed:

Booting from  SATA PS: ATP IG SlimSATA Part1

Blue Coat UEFI Boot v4.11.187414

This machine has the following bootable systems:

>1: Version: ASG 6.6.5.2, Release id: 193352
    Created:    Saturday October 15 2016 19:52:50 UTC
    Last-boot:  Monday February 27 2017 23:11:22 UTC, FAILED
    Attributes: Signed
 2: Version: ASG 6.6.3.2, Release id: 177956
    Created:    Tuesday December 1 2015 00:41:49 UTC
    Last-boot:  Wednesday April 12 2017 00:55:36 UTC, SUCCESS
    Attributes: Locked

The default boot system is:
 1: Version: ASG 6.6.5.2, Release id: 193352

Press the space key to select an alternate system to boot.

Seconds remaining until the default system is booted: 543210

Booting Version: ASG 6.6.5.2, Release id: 193352
[   23.699914] Restarting system.


SCENARIO 2:
​The following example shows the serial output when the appliance gets stuck while attempting to load a newly installed version of ASG:

Booting from  SATA PS: ATP IG SlimSATA Part1

Blue Coat UEFI Boot v4.11.187414

This machine has the following bootable systems:

>1: Version: ASG 6.6.5.2, Release id: 193352
    Created:    Saturday October 15 2016 19:52:50 UTC
    Last-boot:  Thursday December 15 2016 15:53:44 UTC, FAILED
    Attributes: Signed
 2: Version: ASG 6.6.3.2, Release id: 177956
    Created:    Tuesday December 1 2015 00:41:49 UTC
    Last-boot:  Thursday December 15 2016 14:10:09 UTC, SUCCESS
    Attributes: Locked

The default boot system is:
 1: Version: ASG 6.6.5.2, Release id: 193352

Press the space key to select an alternate system to boot.

Seconds remaining until the default system is booted: 543210

Booting Version: ASG 6.6.5.2, Release id: 193352
In MP mode; four processors active
In MP mode; four processors active
In MP mode; four processors active
In MP mode; four processors active

Environment

The following ASG models and software versions are susceptible to this problem:

ASG Models:

ASG-S500-20
ASG-S500-10

ASG-S400-40
ASG-S400-30
ASG-S400-20

ASG-S200-40
ASG-S200-30

Affected ASG Versions:

ASG 6.6.3.2
ASG 6.6.3.3
ASG 6.6.4.2
ASG 6.6.5.1
ASG 6.6.5.2
ASG 6.6.5.4

Cause

Rarely occurring timing issues resulted in configuration inconsistencies that become evident when attempting to load an updated version of ASG.

Resolution

ASG 6.6.5.6 or later includes fixes to address both of the issues outlined above.

ALL customers are strongly encouraged to upgrade to 6.6.5.6 or later.

IMPORTANT:
After upgrading, delete ALL versions of ASG prior to 6.6.5.6 - ONLY ASG versions 6.6.5.6 or later should be left on the appliance.

RECOVERY STEPS
If a unit is failing to load an upgraded version of ASG please perform the following steps to recover the system:

  1. If possible, boot to a working version of ASG and archive the existing configuration.
  2. Install ASG 6.6.5.6 or later
  3. From a serial connection, restart the appliance and use the boot loader 'r' option to reinitialize the appliance to factory defaults (see article https://support.symantec.com/en_US/article.TECH245876.html for more details on how to restore to factory defaults).
  4. Perform the initial configuration
  5. Delete ALL versions of ASG prior to 6.6.5.6 - ONLY ASG 6.6.5.6 or later should be left on the appliance
  6. Restore a archived configuration (if available)

If it is not possible to install ASG 6.6.5.6 or later and the appliance is still experiencing one of the issues listed above please contact support.
Support contact details can be found at the following URL:
https://support.symantec.com/en_US/contact-support.html