Error: "Referenced by Policy" - unable to delete access log on the Proxysg
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Error: "Referenced by Policy" - unable to delete access log on the Proxysg

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Article ID: 170167

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Updated On:

Products

ProxySG Software - SGOS

Issue/Introduction

I want to delete an access log from my proxySG, but I get an error.

The log "<log name>" is referenced by policy.

Cause

Access logs that are referenced by policy cannot be deleted, as they are considered "in use".

Access logs cannot be deleted when global access logging is enabled, as they are still considered "in use".

Resolution

Take the following steps to delete an access log that is no longer needed:

  1. Remove any policy that references the access log you wish to delete.
  2. Disable global access logging (Configuration > Access Log > General)
  3. Delete all log objects from the access log in question.  You can use the following article for commands reference: https://knowledge.broadcom.com/external/article/166064/delete-access-logs-on-edgeswg-formerly-p.html
  4. Select the log you wish to delete, then click on "Delete", then apply changes. (Configuration > Access Log > Logs)
  5. Once the access log has been deleted, you can enable global access logging again.