Unable to process events. This request operation sent to net.pipe://localhost/rss/ClientTaskDataReportingRemotingRequestService did not receive a reply within the configured timeout.
search cancel

Unable to process events. This request operation sent to net.pipe://localhost/rss/ClientTaskDataReportingRemotingRequestService did not receive a reply within the configured timeout.

book

Article ID: 170173

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Tasks statuses are not being reported back to the SMP. The tasks are going out but the SMP Server is not reporting the jobs have run successfully.
The SMP is also the Task Server. In the Console, the task just displays 100% running and doesn't change to complete.

Looking at the SMP logs, the warning that we see when the task is reporting 
as successful is the following:

Unable to process events.
This request operation sent to net.pipe://localhost/rss/ClientTaskDataReportingRemotingRequestService did not receive a reply within the configured timeout (00:02:00).  The time 
allotted to this operation may have been a portion of a longer timeout.  
This may be because the service is still processing the operation or because the service was unable to send a reply message.  Please consider increasing the operation timeout (by casting the channel/proxy to IContextChannel and setting the OperationTimeout property) and ensure that the service is able to connect to the client.
   [System.TimeoutException @ mscorlib]

Server stack trace: 
   at System.ServiceModel.Dispatcher.DuplexChannelBinder.Request(Message message, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData&msgData, Int32 type)
   at Altiris.DotNetLib.IRemotingRequestService.HandleRequest(String service, Hashtable parameters)
   at Altiris.ClientTask.Server.EventReportingManager.ProcessEvents()

Exception logged from: 
   at Altiris.DotNetLib.Logging.AtrsLog.ExceptionMessage(String message, Exception exception)
   at Altiris.ClientTask.Server.EventReportingManager.ProcessEvents()
   at Altiris.ClientTask.Server.EventReportingManager.DoEventReportingLoop()
   at Altiris.ClientTask.Server.EventReportingManager.EventReportingThreadFunc()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()

-----------------------------------------------------------------------------------------------------
Date: 9/7/2017 1:06:10 PM, Tick Count: 881620796 (10.04:53:40.7960000),  Size: 2.58 KB
Process: AtrsHost (118100), Thread ID: 39, Module: AtrsHost.exe
Priority: 2, Source: Task status reporting [EventReportingManager]
 

Environment

ITMS 8.1

Cause

Unknown. Possibly one of the task events got corrupted causing the rest of them to hang in the "C:\Program Files\Altiris\TaskManagement\Events" folder on the SMP.

Resolution

This issue has been reported to the Symantec Development team.

Check if there are any files that are not processed under "C:\Program Files\Altiris\TaskManagement\Events". If you see a large number of files in this directory from older dates, please try the following:

  1. Stop Altiris Support Service, AtrsHost (Altiris Object Host Service) and CTDataLoader (Altiris Client Task Data Loader) services
  2. Go to "C:\Program Files\Altiris\TaskManagement\Events"; please get notice of the date of the first file and last file
  3. Rename the "Events" folder and create a new "Events" folder (if you don't need those events processed again, you can go ahead and delete the files under the "...\TaskManagement\Events" folder
  4. Start the services stopped before above
  5. Please check whether or not the number of files is increasing in that folder again.