Error "Invalid private key file [0x840b0000]" during update of Endpoint Protection Manager certificate
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Error "Invalid private key file [0x840b0000]" during update of Endpoint Protection Manager certificate

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Article ID: 170184

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Updated On:

Products

Endpoint Protection

Issue/Introduction

You attempt the update the Symantec Endpoint Protection Manager (SEPM) certificate using the Manage Server Certificate Wizard and providing a certificate file and private key file. When you complete the steps to browse to the certificate file and private key file, and then click Next, you receive the following error: "Invalid private key file [0x840b0000]".

Error "Invalid private key file [0x840b0000]"

Environment


Cause

The private key is invalid or encrypted.

Resolution

Validate the private key and make sure that it is in PEM format. If the private key is encrypted with a password, use the following command to create an unencrypted copy of the private key:

openssl rsa -in [yourencryptedprivate.key] -out [decryptedprivate.key]

A copy of openssl.exe is on the SEPM, in the following folder:

"[SEPM Install Folder]\apache\bin"

Once you have created a new unencrypted copy of your private key, you may attempt to complete the wizard again.

For more information about safely updating your SEPM certificates, please see the Related Articles section.