LiveUpdate Administrator fails to download content with pool connection errors
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LiveUpdate Administrator fails to download content with pool connection errors

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Article ID: 170295

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Updated On:

Products

Endpoint Protection

Issue/Introduction

Downloads fail after configuring LiveUpdate Administrator (LUA) to download Endpoint Protection (SEP) content. Scheduled downloads may fail immediately or a few minutes into the download job.

In the lua.application.log (default location: %programdata%\Symantec\LiveUpdate Administrator\Logs) one or more of the following errors will be present:

2017-10-10 14:49:46,211 [pool-6-thread-221] ERROR rcl.HttpHelper  - Fatal transport error in download: Timeout waiting for connection from pool

2017-10-10 14:49:46,211 [pool-6-thread-221] INFO  rcl.HttpHelper  - Released connection for HTTP Get Method

2017-10-10 14:49:46,211 [pool-6-thread-221] ERROR rcl.SegmentedDownloader  - Exception while download of file1507631530jtun_sep12l64en170917001c15sds.m30
org.apache.http.conn.ConnectionPoolTimeoutException: Timeout waiting for connection from pool

and:

2017-10-17 13:57:04,441 [pool-3-thread-323] ERROR rcl.SegmentedDownloader - Exception while download of file1508239828jtun_sep12len171004033csds.m30 java.lang.IllegalStateException: Connection pool shut down

 

Cause

This can be caused when the size of the content exhausts LiveUpdate Administrator download thread queues.

Resolution

Workaround

Either or both of the following workarounds work in most scenarios:

#1: Update the connection retry limit and maximum active connections: 

  1. Open lua_static.properties in Notepad (default location C:\Program Files (x86)\Symantec\LiveUpdate Administrator\tomcat\webapps\lua\WEB-INF\classes\), and find the following entries and update the values to following:
    • download.retry.corruptFile=10
    • download.retry.corruptFile.sleep.msec=60000
    • apache.max.con.per.host=200
    • apache.max.active.con=200
      • Note: These values will be based on the environment, but should workaround the issue in most scenarios. Please adjust accordingly if these values do not work in your environment.
  1.  
  2. Save the file and restart the LiveUpdate Administrator services "LUA Apache Tomcat" and "LUA PostgreSQL" for the change to take effect. 

#2: Split up download schedules by product (ie, 14.3, 14.3 RU2, and 14.3 RU3 all in individual download schedules): 

  1. Go to the "Download & Distribute" tab. 
  2. Select your current distribution schedule and select "edit".
  3. in the "Select Products" section select "add".
  4. While noting the necessary products listed here, deselect all but one product. 
  5. Select "Add".
  6. Change the name (to reflect the remaining product), then select "Apply" then "OK". 
  7. Back in the "Download & Distribute" section choose " Add Download".
  8. Name the schedule to reflect the desired product. 
  9. in the "Select Products" section select "add".
  10. Select the desired product.
  11. Select "Add". 
  12. select "Apply" then "OK".
  13. Repeat step 7 through 12 for each new product. 
  14. It is possible to map the one distribution schedule to run after each download, or do create a new distribution schedule for each product, depending on preference. 

Attachments

LUADownloadIssueFix.zip get_app