Client Computer does not stay in Automation when no task is applied.
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Client Computer does not stay in Automation when no task is applied.

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Article ID: 170323

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

In some circumstances you may want to boot a computer into automation and have the client machine simply wait there for additional instructions.  This article discusses how a client can be compelled to boot to automation and wait there for additional instructions.

 

If the known client in automation sees that it does not have a task it will display the message:
“Connection Closed, Session Terminated” and will reboot to the production environment.

Environment

This article refers to Ghost Solution Suite clients that are running the Altiris Deployment Agent. It does not apply to Ghost Standard Tools.

 

Cause

If a “known” client computer does not have a task to perform it will not usually stay booted to an Automation environment - it will check in to the console briefly ("Client record Updated"), the console will report back to that agent that there are no tasks for it to perform, the agent will then reboot to production Windows after displaying the message "Connection Closed, Session Terminated".

“Known” client computers are computers that appear in the “Computers” panel in the Ghost console because:

  1. That machine has the Symantec Deployment Agent installed, or had it installed at some point.
    OR
  2. That machine has booted to automation at some point in the past.

Resolution

Ghost Solution Suite treats new computers differently then managed computers while in automation.  A new computer (unmanaged) will be instructed to wait if it is an automation agent that first communicates with the console.  The machine will appear in the New Computers list.  The computer will stay in automation indefinitely until you schedule work on the machine.

To make a managed computer a new computer:

  1. Shut Down the PC
  2. Delete the record of that PC from the Ghost Solution Suite console. 
  3. Reboot the computer.

(The above steps only apply if you haven't configured Initial Deployment within the Ghost Solution Suite.  With Initial Deployment configured, new computers will either run the default job or be presented with a menu of jobs to choose from.)

OR

  1. Create a Wait job in the Ghost Solution Suite Console. Here are the steps:
    1. ​In the Ghost Solution Suite console click File – New – Job
    2. Type in the name of the job “Wait”
    3. Click the Add button on the right side of the tasks list
    4. Choose "Wait"
    5. Select the appropriate automation environment. If you are using Automation Folders leave it set to Default Automation, otherwise choose the specific PXE environment you prefer. 
    6. Click Finish
  2. Drag and Drop the “Wait” job on to the target computer.
    If the agent is installed the computer should immediately begin to reboot, if the agent is not installed you must then manually restart the client machine. The job must be assigned to the target computer in order to keep it in Automation
    When the client computer has successfully booted to automation and completed the Wait job, the icon in the Ghost console will have a yellow triangle on it. At that point you can run other jobs, or you can go to the command prompt on the client to execute commands. If you run a Create Disk Image task on a client that is already in Automation it must be selected “Do not boot to Production if client is already in Automation pre-boot.” – which cannot be selected if the create image task is set to Prepare using Sysprep which must run in Production Windows.