Error -99 When capturing an image in Ghost Solution Suite 3.X
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Error -99 When capturing an image in Ghost Solution Suite 3.X

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Article ID: 170326

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

Create and/or Deploy image tasks fail with an error in the console of "Error -99"

Environment

The image is not stored in the eXpress share, or the eXpress share (M:\) cannot be mapped by the client in automation.

GSS 3.x

Cause

The path to the image file the is specified in a job is not valid. This can be caused by a credentials problem in the automation configuration, or a pathing error in the image job. This can also be caused by invalid characters in the folder or file name.

Resolution

When an imaging task is created the path that is specified to the image file must be valid according to the client that is in Automation. 

Solution #1: The images are in the default images share, you need to repair the mapping to the default images share.

The most common cause of this problem is a credentials issue in the automation configuration. If the password changes for the user that is specified in automation configuration the map will not be created properly and this error will result.

If you are seeing this error when you are working with image files in the default images share and you are still seeing this error that probably means the default images share has not mapped properly. If the default images share has not mapped properly, this error will appear whenever the path within an imaging job points to an image in the default express share.

To test if the default images share has mapped properly follow these steps:

  1. Verify the eXpress share on the server is "default"
    1. It should point to Program Files (x86)\Altiris\eXpress\Deployment Server
    2. Permissions should indicate Authenticated Users have Full Control
  2. Create a Wait job in the console  The steps for this are in this document: https://support.symantec.com/en_US/article.TECH247897.html )
  3. Apply the Wait job to the target machine.
    When the Wait task has completed go to the client machine. The agent screen should be present with a status of "Client Record Updated".
  4. Go to the Command prompt in the background. (One of the command prompts will have an active cursor, the other will not. You want the one with the active cursor.)

    Is the Prompt "M:\" or "X:\" ?

    If the prompt says "X:\..." that means that M drive does not exist, it did not successfully map the default share and that is probably the reason you are experiencing this error. Check the credentials in your automation configuration by editing the boot configuration, the steps for setting up a configuration are here:
    https://www.symantec.com/connect/articles/creating-boot-media-console-tasks-ghost-solution-suite-3
    If you are using PXE, edit your PXE configuration.
    1. In the Ghost Console click Tool - PXE configuration
    2. Click your configuration
    3. Click Edit
    4. Click Edit Boot Image
    5. Click Edit (Not Next)
    6. Advance through the wizard until step 5
    7. Correct the credentials, then finish the wizard. 

Another test is to try running the net use command to map the drive to the express share at the command prompt.

Here is the documentation for the net use command:

https://technet.microsoft.com/en-us/library/bb490717.aspx

Here is an example of usage of the net use command to map to the express share if the Ghost server is called "GhostServer"

net use m: \\GhostServer\express

If you are unable to map this share at the command prompt you either do not have credentials, or some security has been applied that is stopping the drive mapping from working.  Contact Microsoft for assistance if you are unable to map network drives in your environment.

Solution #2: The images are on a network share.

If your image file is on a network share you should create a mapped drive to the network share within automation. It is easiest if the map to this network share is exactly the same in Automation as it is on the Ghost Server. The steps to configure an additional network drive are specified in this document: https://support.symantec.com/en_US/article.HOWTO125350.html

Solution #3: The images are on a different physical drive that is connected to the Ghost server

If your images are located on a second physical hard drive that is connected to your Ghost server you can either map the second location as a network drive or you can use "mklink" to create a shortcut from your default images share to the new images share.

The steps for using an mklink are in this document:

https://www.symantec.com/docs/HOWTO127731

Solution #4:   Use GhostCast

Unlike a regular imaging task, if you are using GhostCast to distribute an image, the path that is specified in the image job needs to be valid according to the GhostCast Server, not the client in automation. There is no option in the Ghost Solution suite console to define a Create Disk Image job using GhostCast, to use GhostCast to create an image you would need to launch the GhostCast server manually and define the parameters of the job within GhostCast, rather than as a job.  For Distribute Disk Image jobs you can launch GhostCast manually and configure your job, or you can use GhostCast on an imaging job by checking the Data transfer mode (Ghost Only) checkbox and enter a GhostCast server session name. When you click Finish it will offer to launch the GhostCast server for you with the parameters you specified.

Solution #5:   Unusual characters in the image path

Do not use anything other than alphanumeric English characters in your folder or image file name.

Underscores in the folder names can cause this problem.

Non-English characters in the file name can cause this problem.