CCS agent based RBC job shows "Error during communication with the agent" in job message.
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CCS agent based RBC job shows "Error during communication with the agent" in job message.

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Article ID: 170516

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Updated On:

Products

Control Compliance Suite Control Compliance Suite Standards Server Control Compliance Suite Standards Database

Issue/Introduction

Receiving a communication error when running a raw based data collection (RBC) on an agent(s).  However agent ping from the CCS console successfully connects and the agent configuration settings can be downloaded from the agent.  Earlier RBC jobs may have worked fine.

 

Error in console for Job Message is:   <Example>\<Server1>:Error during communication with the agent

Or you could see <Example>\<Server1> : Error during communication with the agent. Either agent is not reachable or file sync failed.

 

NOTE: Windows CCS agent logs shown below.

On the target host, the agent logs (\esm\system\<hostname>\esmagent.log) show:

[#####] [YYYY/MM/DD HH:MM:SS:000] [ERROR] Agent server: Failed to get file 'c:\program files (x86)\symantec\enterprise security manager\esm\bin\dcmodules\Control\FS_Staging\<GUID>\control\windows\cache\<domain>.MDB' from the manager '<CCS Manager hostname>'

[#####] [YYYY/MM/DD HH:MM:SS:000] [ERROR] Agent server: Failed to get file 'c:\program files (x86)\symantec\enterprise security manager\esm\bin\dcmodules\Control\FS_Staging\<GUID>\control\windows\cache\<domain>.MDB' from the manager; connection closed by remote process

 

and may show:

[#####] [YYYY/MM/DD HH:MM:SS:000] [ERROR] Agent server: Failed to open file c:\program files (x86)\symantec\enterprise security manager\esm\bin\dcmodules\AgentManifestFile.xml

 

Environment

CCS 12.6.x

 

Cause

Failure to update or replace the Domain Cache file on the agent due to an issue in the AgentManifestFile.xml file.

 

Resolution

On the agent, delete the files:

"<install path>\enterprise security manager\esm\bin\dcmodules\AgentManifestFile.xml"
"<install path>\enterprise security manager\esm\bin\dcmodules\Control\Windows\ConfigurationSettings.xml"

These files, among other things, keep track of the Domain Cache version, and other settings for synch purposes.  Sometimes these files get corrupted or misread for some reason.

Re-running a Data collection or CER job against the host machine will re-push the "AgentManifestFile.xml", and "ConfigurationSettings.xml" files and the scan should subsequently succeed.